Closed Bug 754759 Opened 8 years ago Closed 7 years ago

Intermittent TEST-UNEXPECTED-FAIL | 752226-1.html or 752226-2.html | assertion count 1 is more than expected 0 assertions, from ASSERTION: Inner window no longer correct!

Categories

(Core :: DOM: Workers, defect)

15 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 774770

People

(Reporter: mbrubeck, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Somewhat frequent failure in debug crashtests since bug 752226 landed.  How important is this assertion - should we back out, annotate, or fix in place?

https://tbpl.mozilla.org/php/getParsedLog.php?id=11717321&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test crashtest on 2012-05-13 08:46:22 PDT for push 5fbb80b8e84f

REFTEST TEST-PASS | file:///home/cltbld/talos-slave/test/build/reftest/tests/content/base/crashtests/752226-1.html | (LOAD ONLY)
REFTEST INFO | Loading a blank page
++DOMWINDOW == 178 (0xa0f4a60) [serial = 272] [outer = 0x9375790]
###!!! ASSERTION: Inner window no longer correct!: 'outer && outer->GetCurrentInnerWindow() == mWindow', file ../../../dom/workers/WorkerPrivate.cpp, line 3983
std::vector<bool, std::allocator<bool> >::resize(unsigned int, bool) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
std::vector<bool, std::allocator<bool> >::resize(unsigned int, bool) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
std::vector<bool, std::allocator<bool> >::resize(unsigned int, bool) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
XRE_AddStaticComponent (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
std::vector<mozilla::plugins::IPCByteRange, std::allocator<mozilla::plugins::IPCByteRange> >::resize(unsigned int, mozilla::plugins::IPCByteRange) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
void std::vector<std::pair<int, int>, std::allocator<std::pair<int, int> > >::emplace_back<std::pair<int, int> >(std::pair<int, int>&&) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
std::vector<base::Histogram*, std::allocator<base::Histogram*> >::push_back(base::Histogram* const&) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
std::vector<base::Histogram*, std::allocator<base::Histogram*> >::push_back(base::Histogram* const&) (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
JSD_GetValueForObject (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
js::SecurityWrapper<js::Wrapper>::~SecurityWrapper() (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
XRE_InitCommandLine (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
XRE_InitCommandLine (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
XRE_main (/home/cltbld/talos-slave/test/build/firefox/libxul.so)
stat (/home/cltbld/talos-slave/test/build/firefox/firefox-bin)
__libc_start_main+0x000000E6  (/lib/libc.so.6)
REFTEST TEST-UNEXPECTED-FAIL | file:///home/cltbld/talos-slave/test/build/reftest/tests/content/base/crashtests/752226-1.html | assertion count 1 is more than expected 0 assertions
REFTEST TEST-START | file:///home/cltbld/talos-slave/test/build/reftest/tests/content/base/crashtests/752226-2.html | 112 / 2053 (5%)
++DOMWINDOW == 179 (0x981fe98) [serial = 273] [outer = 0x9375790]
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file ../../../../../content/html/content/src/nsHTMLMediaElement.cpp, line 1129
REFTEST TEST-PASS | file:///home/cltbld/talos-slave/test/build/reftest/tests/content/base/crashtests/752226-2.html | (LOAD ONLY)
Annotate for now, I think. 752226-1.html just happens to tickle that assertion. I'll try to write a test that asserts on a pre-bug 752226 build to make sure.

(752226-2.html is entirely innocent, but gets the blame if the timing is right)
Assignee: general → nobody
Component: JavaScript Engine → DOM: Workers
QA Contact: general → workers
Attached patch annotate testsSplinter Review
Attachment #623666 - Flags: review?
Attachment #623666 - Flags: review? → review?(Ms2ger)
Attachment #623666 - Flags: review?(Ms2ger) → review+
Tests annotated: https://hg.mozilla.org/integration/mozilla-inbound/rev/b001da365ab7

Please leave this bug open for now.
Whiteboard: [orange] → [orange][tests annotated][leave open]
Blocks: 774770
I unannotated these tests.  If they hadn't been annotated we might have found and fixed bug 774770 sooner.

https://hg.mozilla.org/mozilla-central/rev/e55638d4037a
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: [orange][tests annotated][leave open] → [orange]
Duplicate of bug: 774770
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.