bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Last download location is not remembered

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: hhgygy, Unassigned)

Tracking

SeaMonkey 2.9 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20120429 Firefox/12.0 SeaMonkey/2.9.1
Build ID: 20120429011004

Steps to reproduce:

Trying to save a jpg file


Actual results:

Seamonkey offers my default "MyPictures" folder to save to.
I want to save the jpg file to 'elsewhere' so I save it to 'elsewhere'.
The next time I want to save a jpg file, it again offers the default "MyPictures"


Expected results:

I think(?) it should offer the "elsewhere" folder next time I try to save a jpg and not always the MyPictures.
My download preference is set to "Always ask me where to save files".
(Reporter)

Comment 1

6 years ago
I'm not sure whether it is a duplicate, I found similar unresolved bugs under 
667223 and 432573

Comment 2

6 years ago
As a test, create a new, clean, Profile.
Does the problem persist in that Profile?

---

It does not sound like you have the issue linked below, though it could still be helpful to follow through the tips there & see if anything mentioned helps your situation.

"Unable to save or download files"
http://kb.mozillazine.org/Unable_to_save_or_download_files

---

Links to other bugs mentioned:

Bug 667223
Bug 432573
(Reporter)

Comment 3

6 years ago
If I create a new profile, it does not behave like that so it is something with my current profile...
(Reporter)

Comment 4

6 years ago
OK it seems to have been solved.
I had previously moved my default Windows Downloads folder.
I reset my download preference first to always download to Downloads then I changed the default download folder to something else (MyDocuments).
Finally I again reset the download preference to  "Always ask me where to save files". 
Now it seems to be remembering the last selected download location.

Comment 5

6 years ago
Resolved per comment 4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.