Last Comment Bug 755056 - nsSVGForeignObjectFrame::mRect should include its x/y offset
: nsSVGForeignObjectFrame::mRect should include its x/y offset
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Jonathan Watt [:jwatt] (back in October - email directly if necessary)
:
:
Mentors:
Depends on: 824464
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 14:44 PDT by Jonathan Watt [:jwatt] (back in October - email directly if necessary)
Modified: 2012-12-29 03:24 PST (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.13 KB, patch)
2012-05-14 14:46 PDT, Jonathan Watt [:jwatt] (back in October - email directly if necessary)
longsonr: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-05-14 14:44:29 PDT
nsSVGForeignObjectFrame::mRect should include the offset due to the x/y attributes. The only reason that we currently get away with this bug is because setting mRect's x/y to zero means that nsSVGForeignObjectFrame::InvalidateDirtyRect does the right thing.
Comment 1 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-05-14 14:46:48 PDT
Created attachment 623832 [details] [diff] [review]
patch
Comment 2 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-05-16 03:28:59 PDT
Pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/d5356ca73466
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-05-16 19:33:20 PDT
https://hg.mozilla.org/mozilla-central/rev/d5356ca73466

Note You need to log in before you can comment on or make changes to this bug.