odd experience when doing Google search from within browser

RESOLVED DUPLICATE of bug 754947

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 754947
6 years ago
2 years ago

People

(Reporter: John Slater, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Engagement][creative])

(Reporter)

Description

6 years ago
It's a little hard to describe this, but here's a quick overview of what happened:

Expected behavior:
1. type search term into Aurora's "enter search or address" field
2. see list of Google results
3. select desired result & go to that site

Actual results:
1. I typed "urban orchard" into the search field
2. instead of being taken to a Google results page, I was directed to a particular page (the top one in the results list, I'd assume) not of my choosing
3. when I hit the back button, I was returned to the phone's desktop (effectively taking me out of Aurora altogether) rather than the search results page or some sort of start page

That last part felt the most off to me. Hope that helps.
John, are you running into bug 735115?
(Reporter)

Comment 2

6 years ago
No, not exactly. In this case the search is taking me directly to the page and bypassing the search results page, but once I get there it's a regular web page.
That behaviour should be fixed as of the next nightly. See https://bugzilla.mozilla.org/show_bug.cgi?id=754947#c2

As for the back button issue (step 3 in your actual results), I think that's normal since the page was basically the first page you loaded, and backing out of that page will take you back out of fennec.

Marking as dupe of bug 754947, but feel free to reopen if you think there's still something unaddressed here.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 754947
You need to log in before you can comment on or make changes to this bug.