Content needs a signal for open sidebar

RESOLVED DUPLICATE of bug 777177

Status

()

Firefox
SocialAPI
RESOLVED DUPLICATE of bug 777177
6 years ago
6 years ago

People

(Reporter: mixedpuppy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
moved from https://github.com/mozilla/socialapi-dev/issues/20

We have talked about providing a JS or header-based cue to a site to let it know we are displaying a sidebar. Until we have that figured out, I think we should probably just auto-hide the sidebar when the user visits the provider's site.

How should this be implemented? We could use the prefixURL of the provider metadata, but that's more likely just the part of the site that implements the sidebar and serviceWindows. We could do a domain match, but that's likely to run afoul of http/https variation. Perhaps we should just match on the domain name.
(Reporter)

Comment 1

6 years ago
IMO: this is a provider specific issue.  We should provide a  port into any browser tab belonging to a provider so the social extensions can talk with the normal web content.  That would provide a generic mechanism for providers to do these kinds of custom things.
FWIW, amigo is looking at having their "normal" site detecting the sidebar is open and not display that info on the regular site.
(Reporter)

Updated

6 years ago
Whiteboard: [ms1]

Updated

6 years ago
Whiteboard: [ms1] → [Fx16]

Comment 3

6 years ago
We need to sort this out. I'm asserting that we want to let the site know when its sidebar is open and let them decide how to modify their site. How we do that is the question.
Summary: Auto-hide sidebar on provider's site? → Content needs a signal for open sidebar

Comment 4

6 years ago
For the short term, we're going to ask providers to manage this with cookies or local storage signals.
Whiteboard: [Fx16]
(Reporter)

Comment 5

6 years ago
bug 777177 provides signals to the sidebar itself, and from there providers can use localstorage or something like that to signal regular content about that change.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 777177
You need to log in before you can comment on or make changes to this bug.