Last Comment Bug 755163 - Some jit tests fail with compiler optimizations disabled
: Some jit tests fail with compiler optimizations disabled
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: :Benjamin Peterson
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 19:27 PDT by :Benjamin Peterson
Modified: 2012-05-16 20:17 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
kills the offending test (621 bytes, patch)
2012-05-15 17:25 PDT, :Benjamin Peterson
no flags Details | Diff | Splinter Review
kills offending test (668 bytes, patch)
2012-05-15 17:41 PDT, :Benjamin Peterson
jwalden+bmo: review+
Details | Diff | Splinter Review

Description :Benjamin Peterson 2012-05-14 19:27:54 PDT

    
Comment 1 :Benjamin Peterson 2012-05-14 19:30:43 PDT
Specifically, configure with --disable-optimize and run jit tests to get

FAILURES:
    -m /home/benjamin/dev/repos/y/js/src/jit-test/tests/basic/bug529130.js
    -m -n /home/benjamin/dev/repos/y/js/src/jit-test/tests/basic/bug529130.js
TIMEOUTS:
Comment 2 David Mandelin [:dmandelin] 2012-05-15 16:06:00 PDT
It passes for me on 32-bit Windows and MacOS 10.6. What version of GCC are you using?
Comment 3 :Benjamin Peterson 2012-05-15 16:43:39 PDT
gcc 4.5.3 on Linux.
Comment 4 :Benjamin Peterson 2012-05-15 16:59:40 PDT
The output looks like

|    0.0s1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
1,2,3,4,5,6,7,8,9
/home/benjamin/dev/repos/y/js/src/jit-test/tests/basic/bug529130.js:6: InternalError: too much recursion
Exit code: 3
Comment 5 Jeff Walden [:Waldo] (remove +bmo to email) 2012-05-15 17:03:29 PDT
That's probably because the test recurs a lot, and usable recursion depth depends on the stack space consumed by the compiler.  I consider this test flaky and ignore failures from it, which quite arguably I shouldn't do.  Maybe we should actually fix the test to not recur so close to the overall limit that compiler-dependent stack sizes makes it fail?
Comment 6 :Benjamin Peterson 2012-05-15 17:06:08 PDT
Is this test even very useful? The code for the bug that it fixes is gone with tracing.
Comment 7 David Mandelin [:dmandelin] 2012-05-15 17:20:58 PDT
(In reply to Benjamin Peterson from comment #6)
> Is this test even very useful? The code for the bug that it fixes is gone
> with tracing.

Kill it with fire!
Comment 8 :Benjamin Peterson 2012-05-15 17:25:40 PDT
Created attachment 624252 [details] [diff] [review]
kills the offending test
Comment 9 :Benjamin Peterson 2012-05-15 17:41:49 PDT
Created attachment 624258 [details] [diff] [review]
kills offending test
Comment 10 Paul Wright 2012-05-16 12:07:04 PDT
Is this the only test which exercises code which is no longer in use?  Should there be some audit activities to find out?
Comment 11 :Benjamin Peterson 2012-05-16 12:09:08 PDT
(In reply to Paul Wright from comment #10)
> Is this the only test which exercises code which is no longer in use? 
> Should there be some audit activities to find out?

I'm not sure what you mean. The code which this test tested is gone.
Comment 12 Jeff Walden [:Waldo] (remove +bmo to email) 2012-05-16 12:16:50 PDT
w00t!  Always did find that test annoying.
Comment 13 Jeff Walden [:Waldo] (remove +bmo to email) 2012-05-16 12:17:03 PDT
...ahem:

https://hg.mozilla.org/integration/mozilla-inbound/rev/e1406f8b5d54
Comment 14 Paul Wright 2012-05-16 12:53:03 PDT
(In reply to Benjamin Peterson from comment #11)
> (In reply to Paul Wright from comment #10)
> > Is this the only test which exercises code which is no longer in use? 
> > Should there be some audit activities to find out?
> 
> I'm not sure what you mean. The code which this test tested is gone.

Exactly.  This test tested code which is now gone.  Are there any other tests which also test code which no longer exists?  Is there a way to audit the test suites to find out / clean them up?
Comment 15 Ryan VanderMeulen [:RyanVM] 2012-05-16 20:01:35 PDT
https://hg.mozilla.org/mozilla-central/rev/e1406f8b5d54

Leaving open as it's not clear whether more work is planned for this bug or not. Please resolve it if there isn't.
Comment 16 :Benjamin Peterson 2012-05-16 20:17:18 PDT
No tests failure anymore, so this bug specifically is done.

Note You need to log in before you can comment on or make changes to this bug.