Create compilation flag for mobile HTML5 forms

RESOLVED WONTFIX

Status

()

Core
DOM
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: raphc, Assigned: raphc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120514030523




Expected results:

Implement some HTML5 forms for mobile only
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
(Assignee)

Updated

6 years ago
OS: All → Linux
Hardware: All → x86_64
(Assignee)

Comment 1

6 years ago
Created attachment 624337 [details] [diff] [review]
patch
Attachment #624337 - Flags: review?(mh+mozilla)
Glandium, for information this compilation flag will be used to have some new form elements/input types released only on mobile (because we will not have a UI on desktop).
We could change that later for a run-time pref but I think a pref would be dirtier because we have to initialize some static arrays. So, for the moment, I prefer to go with a compilation flag and see if a pref would be useful and cleaner.
OS: Linux → All
Hardware: x86_64 → All
Comment on attachment 624337 [details] [diff] [review]
patch

Review of attachment 624337 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +7667,5 @@
> +                               on mobile plarforms.],
> +    EXPERIMENTAL_FORMS=1,
> +    EXPERIMENTAL_FORMS= )
> +MOBILE_PLATFORM = `expr "$MOZ_BUILD_APP" : "\(mobile\)"`
> +if test "$MOBILE_PLATFORM" = "mobile" -o "$MOZ_BUILD_APP" = "b2g"; then

That's a very unconventional idiom. Please use something like:
case "$MOZ_BUILD_APP" in
mobile/*|b2g)
    EXPERIMENTAL_FORMS=1
    ;;
esac

instead.

Is there really an interest in having a configure argument for this? It would seem me that no, and that if someone still want to enable it to work on the desktop implementations, they could either broaden the test here, or export EXPERIMENTAL_FORMS=1 in thir mozconfig.
Attachment #624337 - Flags: review?(mh+mozilla) → review-
The main idea of this flag is to allow devs to enable this on desktop. If you prefer exporting EXPERIMENTAL_FORMS instead of the compilation flag, I guess I wouldn't mind.

Raphael, how does that sound to you?
(Assignee)

Comment 5

6 years ago
Created attachment 624424 [details] [diff] [review]
patch 2
Attachment #624337 - Attachment is obsolete: true
Attachment #624424 - Flags: review?(mh+mozilla)
Attachment #624424 - Flags: review?(mh+mozilla) → review+
Assignee: nobody → raphael.catolino
The compile flag solution has been abandoned in favour of the pref one.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.