Closed Bug 755267 Opened 7 years ago Closed 7 years ago

History Tab is still blank after Sync is performed

Categories

(Firefox for Android :: General, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 15
Tracking Status
firefox14 --- fixed
blocking-fennec1.0 --- betaN+

People

(Reporter: xti, Assigned: gcp)

Details

(Keywords: regression, Whiteboard: sync)

Attachments

(2 files)

Firefox 15.0a1 (2012-05-15)
Device: Galaxy Nexus
OS: Android 4.0.2

Steps to reproduce:
1. Open Fennec (clean profile)
2. Perform Sync and wait until it's done
3. Go to Awesomebar > History

Expected result:
After step 3, the History tab is populated with synced data.

Actual result:
History tab is still blank.

Note:
05-15 16:05:05.478: W/HistoryStage(22520): Not enabling history engine since Fennec history is not migrated.
05-15 16:05:05.478: I/ServerSyncStage(22520): Stage history disabled; skipping.
05-15 16:05:05.478: I/SyncAdapter(22520): Stage completed: syncHistory
Whiteboard: sync
Is this before or after a migration? I can't reproduce this, Nightly (05/15).
(In reply to Aaron Train [:aaronmt] from comment #1)
> Is this before or after a migration? I can't reproduce this, Nightly (05/15).

Is it on a clean profile on Native. No profile migration occurs here.
Attached file alogcat - Nightly
I see a lot of this in the log:

D/FormHistoryProvider(24580): Using path: /data/data/org.mozilla.fennec/files/mozilla/n6aeyfeh.default

D/FormHistoryProvider(24580): Successfully created database helper for profile: default

D/FormHistoryProvider(24580): No profile provided, using default
I am guessing that passwords have an issue as well :

D/GeckoPasswordsProvider(25044): Using path: /data/data/org.mozilla.fennec/files/mozilla/ue73ymj9.default
D/GeckoPasswordsProvider(25044): Successfully created database helper for profile: default
D/GeckoPasswordsProvider(25044): No profile provided, using default
    protected void setMigratedHistory() {
        setBooleanPrefTrue(PREFS_MIGRATE_BOOKMARKS_DONE);
    }

doh :(
Regressed in bug 746860.
Keywords: regression
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 746860
User impact if declined: Sync will never work for history on migrated profiles.
Risk to taking this patch (and alternatives if risky): Trivial copypaste error.
Attachment #624050 - Flags: review?(mark.finkle)
Attachment #624050 - Flags: approval-mozilla-aurora?
blocking-fennec1.0: --- → ?
Flags: in-testsuite?
Attachment #624050 - Flags: review?(mark.finkle)
Attachment #624050 - Flags: review+
Attachment #624050 - Flags: approval-mozilla-aurora?
Attachment #624050 - Flags: approval-mozilla-aurora+
blocking-fennec1.0: ? → betaN+
https://hg.mozilla.org/mozilla-central/rev/d9b3e6d2e0ac
Assignee: nobody → gpascutto
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Verified on:
Build: Nightly 15.0a1 2012-05-17/ Aurora 14.0a2 2012-05-17
Device: HTC Desire Z 
OS: Android 2.3.3

History Tab is populated with entries from both before the sync(mobile history) and after the sync.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.