If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

MailNews Core
Filters
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Ulf Zibis, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 624051 [details]
Filters self-disabled.png

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

- TB is not started
- click on mailto link (hidden by JavaScript function) in Firefox browser
  (see: https://www.nicolasbarro.de/kontakt/)
--> message composer window opens
--> dialogue for master password input
--> acoustic signal about new messages
- start TB by normal short-cut to avoid missing new messages
- finish email composing and send



Actual results:

--> many emails in POP3 inbox folder which should have been filtered
- open Extras->Filter
--> some filters are disabled, see attachment


Expected results:

All filters should remain enabled as usual.
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Similar "filter disable upon mail download after Tb 12" is reported to bug 751562 and bug 752866.
Do you see problem even when Tb is started before mailto: link click?
(Reporter)

Comment 2

6 years ago
1. I see this problem since years, long before TB 12, but very rare: 2..5 times a year, but never had an idea about the "reason". So it was difficult to estimate about reproducible steps.
2. I don't see the problem when Tb is started before mailto: link click.
3. I do not often use mailto: links, little more I use Windows Explorer's context-menu->sendTo. Mostly my Tb is running all day, so I do not remember if there was some context with those actions, and also do not remember weather the mailto: links were invoked by JavaScript or directly from HTML.
4. After I manually enabled the filters again and run filters on folder, the "new mail indications" (orange flower + blue folder) were lost on the local target folders. Is there any bug about that?
(Reporter)

Comment 3

6 years ago
5. I use master password since short time, so former occurrences of this bug were without master password.
6. IIRC, maybe in former times there was some context with Tb update as bug 751562 describes, but this time it was definitely not related to 12.0.1 update, as the update was done some days before. I could not see that the previously saved folder selection for the "Move to" operation has been blanked out.
Do you have mail folder which was created by manual copy of a set of a-file/a-file.msf?

If FileA/FileA.msf(string of File-A is written in .msf) is copied to FileB/FileB.msf(string of File-A is still written in .msf), FolderA is shown at folder pane for both folder, and is saved in panacea.dat.
  Folder Pane(panacea.dat data)  folder file  msf file      string in .msf
   FolderA                        FolderA      FolderA.msf    FolderA
   FolderA                        FolderB      FolderB.msf    FolderA
This is a phenomenon of bug 752423.

Because file name is used in internal path of folder and the internal path is writte in msgFilterRules.dat, problem perhaps won't usually occur even though FolderA is shown for FolderB/FolderB.msf.
However, FolderA is shown at messae filter rule panel. So it surely produces user's confusion.

Because "string in .msf" is actual mail folder name in next case,
  Special char is used in folder name, then file name is hashed.
  <string><hashed_string>.msf is used. File name is used in internal path.
  Folder Name = string saved in .msf file.
"Folder Name at folder pane != Actual file name of internal path" may produce "folder not found" in some circumstances.
Other concerns - silent auto-compact while filter move, out-dated-msf.

What is your auto-compact related settings?
  mail.prompt_purge_threshhold : true = auto-compact is enabled
  mail.purge.ask : true  = confirmation dialog before auto-compact is shown
                   false = auto-compact is executed without confirmation dialog
  mail.purge_threshhold_mb

If Tb did not terminate normally, mismatch between "actual timestamp/size of Inbox file" and "timestamp/size data in Inbox.msf for Inbox file" can occur.
"Killing Tb by Task Manager" will produces this condition.
In this case, internal rebuild-index(==Repair Folder) is automatically invoked upon mail folder open. This internal rebuild-index may interfere filter move just after restart of Tb.

Was your Tb always terminated normally?
(Reporter)

Comment 6

6 years ago
(In reply to WADA from comment #4)
> Do you have mail folder which was created by manual copy of a set of
> a-file/a-file.msf?

No, none of these local folders were created by manual copy.

(In reply to WADA from comment #5)
> What is your auto-compact related settings?

  mail.prompt_purge_threshhold : true
  mail.purge.ask : true
  mail.purge.min_delay : 480
  mail.purge_threshhold_mb : 10

> Was your Tb always terminated normally?

Normally yes, but there have been cases, where Windows was unresponsive, so I had to power-off.
Another concern - large file size.
"File size greater than 2B" was referred in bu 754508 comment #33. Because Tb 12 still has bug 725810(auto-compact is not invoked. opossite issue of bug 750569 exists too.), large file size can occur, and it may produce some problems.

Do you have mail folder file largr than 2GB? (file of Inbox instead of Inbox.sbd if Inbox folder, file of FolderX.sbd\SubfolderY if SubfolderY undr FolderX)

(In reply to Ulf Zibis from comment #3)
> 6. IIRC, maybe in former times there was some context with Tb update as bug
> 751562 describes, but this time it was definitely not related to 12.0.1
> update, as the update was done some days before.

Did you upgrade from Tb 11 or older to Tb 12.0.0 then upgrad to Tb 12.0.1?
If so, Tb 12.0.0 use may be relevant to problem, because Tb 12.0.0 had problem like bug 736539, bug 730947 which produces bad .msf data by filter move. Even after fix of those bugs by Tb 12.0.1, bad data in .msf generated by Tb 12.0.0 won't be cleared until "Repair Folder" is executed or "delete .msf and restart Tb" is executed.

Did you use Tb 12.0.0 with "filter move" enabled?

Comment 8

6 years ago
(In reply to WADA from comment #7)

> Did you upgrade from Tb 11 or older to Tb 12.0.0 then upgrad to Tb 12.0.1?
> If so, Tb 12.0.0 use may be relevant to problem, because Tb 12.0.0 had
> problem like bug 736539, bug 730947 

That's true for 12.0 betas but not the 12 build that shipped.

Comment 9

5 years ago
So to rule out dupes, is this still happening in TB14 that has bug 751562 fixed?
(Reporter)

Comment 10

5 years ago
Additional comment to trigger behaviour while TB 14 is closed.
(Reporter)

Comment 11

5 years ago
I did not success to reproduce the problem with TB 14 after some trials, but this will say nothing, as the problem occurred rarely.
Note 1: the above given javascript link doesn't exist any more, so I used info link from www.JUGKoeln.de.
Note 2: This time I had collapsed the root folder of folder where messages were moved to.
Note 3: in TB 14 I don't see the dialogue for master password input or the acoustic signal about new messages any more after invoking mailto: link, but after later additional normal start by desktop short cut.

There are differences from bug 751562:
- IIRC I never got the "The folder 'Abc' could not be found ..." message.
- The destination folders of the filters were not blanked, just the filters were disabled.
- Normally all my folders are expanded (because of bug 763534). But sometimes folders were collapsed after start for unknown reason, don't remember if there was a relation to this bug.
- I experience the problem since many years, long before 12.0.1, but rarely.

Maybe there is some relation to bug 755317, as IIRC, the problem always occurred after resume from hibernation.

(In reply to WADA from comment #7)
> Do you have mail folder file largr than 2GB? (file of Inbox instead of
> Inbox.sbd if Inbox folder, file of FolderX.sbd\SubfolderY if SubfolderY undr
> FolderX)

No!

> Did you use Tb 12.0.0 with "filter move" enabled?

I always had enabled the filters, but I'm not sure if I ever run 12.0.0. I remember with 75 % probability I updated from 11 to 12.0.1.

Comment 12

5 years ago
unless I misunderstand, it would be reasonable assume this is a dup of bug 751562
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 751562
(Reporter)

Comment 13

5 years ago
I suspect, whether this bug is a dupe of bug 751562, because ...

(In reply to Ulf Zibis from comment #11)
> There are differences from bug 751562:
> - IIRC I never got the "The folder 'Abc' could not be found ..." message.
> - The destination folders of the filters were not blanked, just the filters
> were disabled.
> - Normally all my folders are expanded (because of bug 763534). But
> sometimes folders were collapsed after start for unknown reason, don't
> remember if there was a relation to this bug.
> - I experience the problem since many years, long before 12.0.1, but rarely.
> 
> Maybe there is some relation to bug 755317, as IIRC, the problem always
> occurred after resume from hibernation.

Another question is not answered too:

(In reply to Ulf Zibis from comment #2)
> 4. After I manually enabled the filters again and run filters on folder, the
> "new mail indications" (orange flower + blue folder) were lost on the local
> target folders. Is there any bug about that?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 14

4 years ago
Ulf,
- the targets are always local folders?
- have you seen this ever in version 17?  version 24?
- anything seen in error console?  activity manager
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Comment 15

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #14)
> - the targets are always local folders?
Yes, and source was POP account.
> - have you seen this ever in version 17?  version 24?
No, but I didn't trigger it.
> - anything seen in error console?  activity manager
No.

I tried to reproduce with Ubuntu, because my Windows is broken. Ubuntu behaviour is little different:
- after "message composer window opens", no "dialogue for master password" pops up.
- therefore no "acoustic signal about new messages"
- With open message composer window I can't start normal TB UI from Ubuntu's starter icon, but it was possible from terminal with "thunderbird". Is that as designed?
... so the steps have little changed on Ubuntu:

- TB is not started
- click on mailto link (hidden by JavaScript function) in Firefox browser
  (see: http://www.jugkoeln.de/)
--> message composer window opens
- start TB from terminal to avoid missing new messages
--> dialogue for master password input
--> acoustic signal about new messages
- finish email composing and send

After this I didn't experience the error, I guess because there were no incoming mails to filter.
I'll try again tomorrow.
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Comment 16

4 years ago
I tried on my broken Windows and discovered a different behaviour also there, but couldn't surly test the test case:
- after "message composer window opens", no "dialogue for master password" pops up.
- therefore no "acoustic signal about new messages"

On Linux, the error was not reproducible this morning upon new incoming and successfully filtered mails.
(Reporter)

Comment 17

4 years ago
For now I would say ...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.