Closed Bug 755423 Opened 8 years ago Closed 8 years ago

If you install into a protected directory which is not Program Files, updates fail

Categories

(Toolkit :: Application Update, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 572162

People

(Reporter: vladan, Unassigned)

Details

Attachments

(1 file)

Attached file Error console log
I have two different 32-bit Nightlies installed on my Windows system, one in C:\Program Files\Nightly\ and the other in C:\Program Files (x86)\Nightly. The one in C:\Program Files\Nightly\ fails to update with the Help->About dialog instructing me to download the newer version manually: "Updates available at http://nightly.mozilla.org/"

When app.update.log is set to true, the error console shows the updater got "permission denied" while trying to create C:\Program Files\Nightly\update.test (see attachment)
Are you running as an admin? Did the same user account initiate both installs?
(In reply to Brian R. Bondy [:bbondy] from comment #1)
> Are you running as an admin? Did the same user account initiate both
> installs?

I'm running with a user account that has admin privileges. I used the same account for everything.
I can reproduce when installing a 32-bit build into Nightly.  I'm not sure this is a supported config but we should probably look into it because it's pretty strange. 
Maybe something related to filesystem redirection.
> I can reproduce when installing a 32-bit build into Nightly

I mean into: 
C:\Program Files\Nightly\
gCanApplyUpdates usually tests for apply access to:
C:\users\user\appdata\local\Mozilla\Firefox\Nightly\update.test

But when Firefox is installed into a C:\Program Files\ directory it tries here:
C:\Program Files\AltInstallDir\udpate.test

The problem is just that if we aren't installed into Program Files, we use the install dir as the udpate dir. This causes a problem if you install into a location that requires elevated permissions to write to which is not the program files (Program Files (x86) on x64 systems) directory.

I think the code has always been this way.
Summary: Nightly fails to update - permission denied to create Nightly\update.test → If you install into a protected directory which is not Program Files, updates fail
Ya that work can cover this work, thanks for linking it up.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 572162
You need to log in before you can comment on or make changes to this bug.