server-full views are not compatible with services.user API

RESOLVED FIXED

Status

Cloud Services
Server: Other
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: rfkelly, Assigned: rfkelly)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa?])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
The server-full package defines some custom account-management views, but they're not compatible with the new services.user API.  They need to grow the same special-casing logic as things like server-reg.
Whiteboard: [qa?]
(Assignee)

Comment 1

6 years ago
Created attachment 626311 [details] [diff] [review]
patch to use newstyle auth backend APU

Given Bug 731522, I don't see any point in trying to support both old-style and new-style backends here.  Attached patch changes things to support *only* the new-style API.
Attachment #626311 - Flags: review?(telliott)
Comment on attachment 626311 [details] [diff] [review]
patch to use newstyle auth backend APU

Patch is fine, but let's make it clear in the documents/checkin summary that it's no longer compatible with the old auth object.
Attachment #626311 - Flags: review?(telliott) → review+
(Assignee)

Comment 3

6 years ago
http://hg.mozilla.org/services/server-full/rev/8af97e47bd0e
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.