BasicTiledLayerBuffer::PaintThebes passes aPaintRegion as the region to invalidate to mCallback

RESOLVED FIXED in Firefox 14

Status

()

Core
Graphics: Layers
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ajuma, Assigned: BenWa)

Tracking

Trunk
mozilla15
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox12 unaffected, firefox13 unaffected, firefox14+ fixed, firefox15 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
This is triggering a never-ending cycle of invalidation for some reftests.
(Assignee)

Comment 1

5 years ago
Created attachment 624147 [details] [diff] [review]
patch
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #624147 - Flags: review?(roc)
Attachment #624147 - Flags: review?(roc) → review+
(Assignee)

Comment 2

5 years ago
I'm not ready to uplift this but let's put it on trunk and keep an eye on this.
tracking-firefox14: --- → ?
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/ab1cd425d884
(Assignee)

Comment 4

5 years ago
Backed out but wasn't the real cause of Talos regression.

re-landed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/19cfd6fb3c57
https://hg.mozilla.org/mozilla-central/rev/19cfd6fb3c57
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla15

Updated

5 years ago
tracking-firefox14: ? → +
BenWa, now that there's been some time on trunk are you ready to nominate for aurora?
(Assignee)

Comment 7

5 years ago
Comment on attachment 624147 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 739679
User impact if declined: Needless painting under certain conditions
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none
Attachment #624147 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

5 years ago
(In reply to Benoit Girard (:BenWa) from comment #7)
> Risk to taking this patch (and alternatives if risky): low

and mobile only

Comment 9

5 years ago
Comment on attachment 624147 [details] [diff] [review]
patch

[Triage Comment]
Approved for Aurora 14.
Attachment #624147 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/a5bae202976b
status-firefox12: --- → unaffected
status-firefox13: --- → unaffected
status-firefox14: --- → fixed
status-firefox15: --- → fixed
You need to log in before you can comment on or make changes to this bug.