Last Comment Bug 755457 - Switch tests to using MozReftestInvalidate to avoid random failures
: Switch tests to using MozReftestInvalidate to avoid random failures
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Jonathan Watt [:jwatt] (back in October - email directly if necessary)
:
:
Mentors:
Depends on:
Blocks: 734082
  Show dependency treegraph
 
Reported: 2012-05-15 12:39 PDT by Jonathan Watt [:jwatt] (back in October - email directly if necessary)
Modified: 2012-05-16 19:33 PDT (History)
2 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.21 KB, patch)
2012-05-15 12:39 PDT, Jonathan Watt [:jwatt] (back in October - email directly if necessary)
longsonr: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-05-15 12:39:23 PDT
Created attachment 624149 [details] [diff] [review]
patch

My patch for bug 734082 seems to expose random failures due to using 'load' instead of 'MozReftestInvalidate' in:

  layout/reftests/svg/smil/anim-filter-primitive-size-01.svg
  layout/reftests/svg/smil/anim-filter-size-01.svg

This patch fixes them.
Comment 1 Robert Longson 2012-05-16 01:33:23 PDT
Comment on attachment 624149 [details] [diff] [review]
patch

You should add a setTimeout as well as the MozReftestInvalidate to make the reftests work on non-gecko browsers. E.g.

    setTimeout(run, 5000);
Comment 2 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-05-16 03:28:43 PDT
Pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/8bcad5a81a3d
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-05-16 19:33:47 PDT
https://hg.mozilla.org/mozilla-central/rev/8bcad5a81a3d

Note You need to log in before you can comment on or make changes to this bug.