[PersonaRebrand] Implement new branding on Affiliates

VERIFIED FIXED in Future

Status

Firefox Affiliates Graveyard
affiliates.mozilla.org
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Laura Forrest, Assigned: mkelly)

Tracking

unspecified
Future
Bug Flags:
in-testsuite ?
in-moztrap ?

Details

(Whiteboard: u=admin c=UI p=1)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
You are using Persona - which is awesome!

Now that Persona has a new look, feel, and name, let's update to the latest and greatest. 

Overview of current branding:
http://people.mozilla.org/~smartell/persona/

Suggested Changing:
- Change copy to mention Persona instead of BrowserID
- Use new sign in buttons
- You may only want to use one Persona button instead of the sign in, register dual buttons you offer now (Dan C. can provide more details if needed). Since they do the same thing, I believe only one is needed. 

Suggested Copy Changes:

Mozilla Persona is here!
Firefox Affiliates now uses Persona to help login. If you previously had an account, use the login button below and sign up for Persona with the same email address you used for signing up with Firefox Affiliates.

Don't have an account?
Want to be a Firefox Affiliate? Sign up using Persona by clicking the registration button below.

It would be great to see these changes go live by the end of the quarter, by June 29th, within the next 6 weeks, or sooner. Let me know if you have any questions!
(Reporter)

Updated

6 years ago
Blocks: 755456

Comment 1

6 years ago
Just to clarify, this content should here? https://persona.org/

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All

Comment 2

6 years ago
Hey Laura. When you file bugs that involve copy or design, will you make sure to use the regular copy and/or design components? Otherwise Tara and I don't necessarily see them and can't assign resources, etc.

Thanks.

Updated

6 years ago
Flags: in-testsuite?
Flags: in-moztrap?
Hey, this is great. We've been waiting to pull the trigger on this since February. Is this branding final?
(Reporter)

Comment 4

6 years ago
Hi guys - for clarity I'm talking about making changes to the Persona treatment on this page: http://affiliates.mozilla.org/

Chelsea: Yes, this branding is final. 

John: No new creative is needed - ideally every site should be able to use the basic assets that Sean has created already. 

Thanks!
Awesome. Matej can you have a glance at the copy to make sure it's up to snuff? We also need to make a change to the copy in the main body section as well, but I'll file another bug for that. 

Once copy is approved we can merge the strings for l10n and get hoppin'.

Comment 6

6 years ago
Made some tweaks. Here it is:


Mozilla Persona is here!
You can now use Persona to log in to Firefox Affiliates. If you previously had an account, click the login button below and sign up for Persona with the same email address you used to sign up for Firefox Affiliates.

Don't have an account?
If you'd like to be a Firefox Affiliate, click the registration button below and sign up using Persona.
OS: All → Mac OS X
Hardware: All → x86
(Reporter)

Comment 7

6 years ago
Looks good!

Chelsea - how do you recommend we get this over to l10n? Can we push the en-US version while that l10n is happening?
I don't think we can push EN-US on its own. Once Flicks is complete we can add this to the Affiliates push schedule. We have a bunch of other items to send to l10n so this is well timed. I'll update you when we have more solid dates but Q2 is totally doable.
Laura, we have one brand question. We have a button on the affiliates site that says "Log In' and has a little "ID" icon on it. Should we change this to a little person icon or just leave it?

Let us know and we can get moving on this.
(In reply to Chelsea Novak [:chelsea] from comment #9)
> Laura, we have one brand question. We have a button on the affiliates site
> that says "Log In' and has a little "ID" icon on it. 

Currently live? Can I see a screenshot or link?


Should we change this
> to a little person icon or just leave it?
> 
> Let us know and we can get moving on this.
Oops--sorry I missed this.  Yes, lets please change this to the person instead of ID on the arrow per the glyph section of http://people.mozilla.com/~smartell/persona/
Product: Websites → Firefox Affiliates
Duplicate of this bug: 788895
(Assignee)

Comment 14

6 years ago
Can we get an updated version of the button image with the person silhouette?
mkelly, will the buttons above work?
So it looks like we need the persona button in a different blue so it coordinates better with the rest of Affiliates. 

John is there someone on the creative team who can help us or should we wait for Ty to come back next week?
There is also a pure-CSS version available on the MDN page, which should be easier to tweak the colors on.

Otherwise, a source PSD can be found on SMartell's page, http://people.mozilla.com/~smartell/persona/

Comment 19

6 years ago
If you need it ASAP Lee can help (just ping him). Otherwise Ty can take this when he's back next week.
mkelly, if the css version will work for you, let's go with that. Otherwise I'll ask Ty when he's back. 

Thanks!
(Assignee)

Comment 21

6 years ago
The CSS version will work if you're okay with changing the look of our buttons; currently we have big blue buttons with a silver arrow as seen in http://cl.ly/100L3D452H3R1S0C0L11, while the sample buttons look significantly different: https://developer.mozilla.org/files/3969/plain_sign_in_blue.png

Is that okay, chelsea?
(Assignee)

Comment 22

6 years ago
Wait, ignore me. I'm just being dumb.
(Assignee)

Comment 23

6 years ago
For clarification, that means we're good, cousin mkelly was just being silly. Thanks!

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Updated

6 years ago
Whiteboard: u=admin c=UI p=1
Target Milestone: --- → Future
(Assignee)

Updated

5 years ago
Duplicate of this bug: 799539
(Assignee)

Comment 25

5 years ago
ozten brought up a good point: Do we want to change the copy around the current Affiliates Persona buttons to be more concise? /me looks at chelsea :P
:)

I think it's time. We've had Persona in place for 10 months. I think that's a pretty generous transition period for people using the old system. Could we just get rid of the upper box completely? /me looks at mkelly
Okay, as per irc convo

Replace the top copy with 

Log In with Persona
Hi all,

Unless there's some good reason not to, can we say "sign in" instead? That's what I've been trying to standardize.

Also, "in" shouldn't be capitalized.

Sign in with Persona

Thanks!
(Assignee)

Comment 29

5 years ago
Created attachment 682597 [details]
Screenshot of front page

Attaching a screenshot of my progress thusfar. The button is functionally complete, but that side box looks a little bare. From the discussion above and my foggy memory I thought we had decided to remove most of the content, but it makes the page look... poor. Any ideas?

(I also may have misunderstood; perhaps we just want to replace all occurances of the word "BrowserID" with "Persona" and update the buttons?)
(Assignee)

Updated

5 years ago
Assignee: nobody → mkelly
I think the old content was pretty of date as it referenced the login system we launched with over a year ago. 

Could we move the sharing buttons over maybe?
(Assignee)

Comment 31

5 years ago
Created attachment 687274 [details]
Screenshot with social buttons moved

It looks better, although I'm still not 100% on it and can't figure out how to make it look better. Thoughts?
Comment on attachment 687274 [details]
Screenshot with social buttons moved

What if you have the sharing box it's own box?
(Assignee)

Comment 33

5 years ago
Created attachment 687914 [details]
Screenshot with added box

Good call! I also took a string from the Facebook site and added it to help balance out the box (it looked odd without a title, smarter people than I can say if it is a good addition or not).

IMO this would work, thoughts?
Comment on attachment 687914 [details]
Screenshot with added box

Works for me!

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 36

5 years ago
Verified fixed on production: https://affiliates.mozilla.org/
Status: RESOLVED → VERIFIED
Product: Firefox Affiliates → Firefox Affiliates Graveyard
You need to log in before you can comment on or make changes to this bug.