All users were logged out of Bugzilla on October 13th, 2018

Grooveshark - E/GeckoConsole( 4031): [JavaScript Warning: "HTTP "Content-Type" of "audio/mpeg" is not supported.

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: bug.zilla, Unassigned)

Tracking

Firefox 15
ARM
Android

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

Log
5.00 KB, text/plain
Details
(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Visited http://html5.grooveshark.com/ and tried to play a song


Actual results:

Songs are added to the queue but do not play. Stock browser plays them with no issues. 


Expected results:

Songs should be played correctly.
Evangelism for right now. We are looking to have mp3/aac/h.264 support in the future.
Component: General → Evangelism
OS: Windows 7 → Android
QA Contact: general → evangelism
Hardware: x86_64 → ARM

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: E/GeckoConsole( 4031): [JavaScript Warning: "HTTP "Content-Type" of "audio/mpeg" is not supported. → Grooveshark - E/GeckoConsole( 4031): [JavaScript Warning: "HTTP "Content-Type" of "audio/mpeg" is not supported.
I guess support is added in bug 422540.
(Reporter)

Comment 3

6 years ago
Hi Martjin, unfortunately I still the same issue.
Thanks
Update: Tested on mozilla-inbound (w/bug 759945 enabled), and playback functionality is still inoperable. Tapping the 'Play' control still yields this error.
(In reply to Aaron Train [:aaronmt] from comment #4)
> Update: Tested on mozilla-inbound (w/bug 759945 enabled), and playback
> functionality is still inoperable. Tapping the 'Play' control still yields
> this error.

Builds now supported. This is fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

6 years ago
Apologies if I'm missing something - this is still broken for me on 18.0a1 (2012-09-22).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This still works for me on my Galaxy Nexus, it is using the new OMX Media Plugins in Gecko and very well may be having issue on your device. Which device are you using? Can you capture any log output from the Android SDK ADB utility and paste it here; particulariy any output from OMXClient.
(Reporter)

Comment 8

6 years ago
Hi, it's a Samsung Galaxy S i9000.

Not sure how to capture output using the Android SDK ADB utility.
Would aLogcat work?

Thanks
(In reply to bug.zilla from comment #8)
> Hi, it's a Samsung Galaxy S i9000.
> 
> Not sure how to capture output using the Android SDK ADB utility.
> Would aLogcat work?
> 
> Thanks

Yes
(Reporter)

Comment 10

6 years ago
Created attachment 666303 [details]
Log
(Reporter)

Updated

6 years ago
Attachment #666303 - Attachment is obsolete: true
(Reporter)

Comment 11

6 years ago
Now with correct attachment
(Reporter)

Comment 12

6 years ago
Created attachment 666311 [details]
Log
(Reporter)

Comment 13

6 years ago
Possibly related to https://bugzilla.mozilla.org/show_bug.cgi?id=795744
Currently no Gingerbread support for H.264/MP3/AAC; see bug 795744 comment #2 - I had forgotten. Thanks for posting the related bug.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
You need to log in before you can comment on or make changes to this bug.