Grouped console messages are not well delineated visually

RESOLVED WORKSFORME

Status

defect
P3
normal
RESOLVED WORKSFORME
7 years ago
10 months ago

People

(Reporter: ianbicking, Unassigned)

Tracking

15 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
When using console.group() and console.groupEnd() all they do is indent the messages.  The items could be better grouped together visually, and could be collapsed.

Also console.group('Title') seems like it would sensibly create a group with a headline 'Title'.  Instead it seems equivalent to console.group(); console.log('Title');.  I don't see any reason for console.group to take an argument unless it is treated distinctly from console.log().

Firebug offers an example of how to better display groupings.
Priority: -- → P3
Duplicate of this bug: 872339
Duplicate of this bug: 971882

Comment 3

5 years ago
The method name itself is suggesting that group should be collapsed. Imagine my surprise when it wasn't and its contents were polluting the console (stack traces are ugly :)

Please fix this.
Mentor: mihai.sucan
See Also: → 704252
Mentor: mihai.sucan
See Also: → 1044050
console.group are now collapsible in the new console frontend.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.