Last Comment Bug 755578 - simplify Compiler::generatePrologue (a tiny bit)
: simplify Compiler::generatePrologue (a tiny bit)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Luke Wagner [:luke]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 16:54 PDT by Luke Wagner [:luke]
Modified: 2012-05-18 18:20 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (4.87 KB, patch)
2012-05-15 16:54 PDT, Luke Wagner [:luke]
bhackett1024: review+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2012-05-15 16:54:11 PDT
Created attachment 624240 [details] [diff] [review]
patch

Tiny preparation bits:
 - s/invokeLabel/fastEntryLabel/, because its not the (invoke entry label)
 - merge it with fastPath label
 - remove script->needsArgsObj() conjunct (it doesn't get created in the prologue)
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-05-18 18:20:30 PDT
https://hg.mozilla.org/mozilla-central/rev/f7bde9f96a91

Note You need to log in before you can comment on or make changes to this bug.