AttributeAffectsStyle should be educated about HTML stylistic attributes so it can do its magin on HTML elements too

VERIFIED DUPLICATE of bug 75561

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 75561
17 years ago
17 years ago

People

(Reporter: Marc Attinasi, Assigned: Marc Attinasi)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
AttributeAffectsStyle currently cannot apply to HTML elements because of the
implicit mapping of many HTML attributes to style properties. This makes it
impossible to rely on the occurrance of a style rule with a given attribute
selector for determining if the attribute will actually affect style. If we
simply mapped the HTML stylistic attributes, possibly by element type, then we
could probably get a big improvement in cases where non-stylistic attributes are
changed and we end up reresolving style anyway.

There is a bit of analysis to do here, like, where is the best place to do this?
Currently, each HTML element is responsible for mapping their attributes to
style properties, so they probably know best which ones are stylistic and which
are not. Then again, a simple table of stylistic attributes could do the trick
too...

Some discussion of this has occurred on bug 68821.
(Assignee)

Comment 1

17 years ago
Accidentally added thsi bug twice - duping this one to the first.

*** This bug has been marked as a duplicate of 75561 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.