If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Offline detection with a virtualbox virtual machine doesn't seem to work

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: David, Unassigned)

Tracking

12 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120310010757

Steps to reproduce:

I am testing Thunderbird (12 or any other version) on a virtual machine (Virtual Box). For information the Virtual Machine is a Windows XP SP3 and the real machine is Ubuntu. To reproduce the problem, just start Thunderbird on the Virtual Machine. Check that offline.autoDetect is set to TRUE. Then disconnect the network on the real machine.


Actual results:

Thunderbird doesn't detect the offline mode.


Expected results:

Thunderbird should detect that the network is down but it detects that only if you deactivate the inferface on the virtual machine.

Comment 1

5 years ago
(In reply to David from comment #0)
Can you try that in the host machine just to see if it works?
(Reporter)

Comment 2

5 years ago
Yes, it works on the host machine.
Roland you still use virtual box ?
Summary: Offline detection with a virtual machine doesn't seem to work → Offline detection with a virtualbox virtual machine doesn't seem to work

Comment 4

5 years ago
(In reply to David from comment #2)
> Yes, it works on the host machine.

Then it seems the type of network connection you use between host and virtual machines is the reason for this. You might want to refer to the virtual machine vendor/developer.
(Reporter)

Comment 5

5 years ago
Furthermore, it doesn't work on a (host) machine with Microsoft Windows 7. Thunderbird doesn't detect online/offline mode. Can anyone confirm that ?
Version: 10 → 12
(In reply to David from comment #5)
> Furthermore, it doesn't work on a (host) machine with Microsoft Windows 7.
> Thunderbird doesn't detect online/offline mode. Can anyone confirm that ?

It does and does work on vmware. Can you try updating your network drivers ?
(Reporter)

Comment 7

5 years ago
My network drivers are up to date. I tried on two different physical machines and I couldn't get it to work on Windows 7. 
I have two interfaces (wifi and Ethernet). I deactivate the wifi interface and activate the Ethernet interface. When I start Thunderbird, if I unplug the Ethernet wire, Thunderbird doesn't detect that I got offline. 
Moreover, if I deactivate the Ethernet interface and activate just the wifi, when I disconnect from my network TB doesn't detect it neither.

So as far as I am concerned, on physical machines : 
- WINDOWS XP (SP3) : SUCCESS, it works well
- LINUX (Ubuntu 11.04) : SUCCESS, it works well
- WINDOWS 7 : FAIL, it doesn't work at all.

and on virtual machines : 
- VirtualBox (with WINDOWS XP) : FAIL, it doesn't work except if you deactivate all network interfaces.
- VMWare (with WINDOWS XP) : SUCCESS PARTIAlLY, it works but after disconnecting a Ethernet wire VMWare rebuild the network interface after 5sec, so then TB goes online where it should not because I have no access to Internet.

I don't really mind if it doesn't work on virtual machines, but on windows 7 it's a problem. Are you sure it should work on this OS ? Is anyone else experiencing the same troubles than me ?
(In reply to David from comment #7)

> I don't really mind if it doesn't work on virtual machines, but on windows 7
> it's a problem. Are you sure it should work on this OS ? Is anyone else
> experiencing the same troubles than me ?

Not that I know of.
Component: General → Untriaged
Do you still see this in version 17 or newer? 
If not, please close by setting status to resolved, and resolution to worksforme.
If it fails, please supply additional information.
Thanks
Whiteboard: [closeme 2013-04-20]
(Reporter)

Comment 10

5 years ago
No it still doesn't work in version 17 and I guess it will never be.

But I don't think TB is responsible for this. It only checks if the network interface is down. But on a virtual machine, even if you unplug the Ethernet wire of your computer, the interface is still up. So TB cannot detect you couldn't go on the Internet.

Comment 11

4 years ago
Resolved per whiteboard and Comment 10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Whiteboard: [closeme 2013-04-20]
You need to log in before you can comment on or make changes to this bug.