Reps Dev instance is not fetching latest commits

VERIFIED FIXED

Status

Mozilla Reps
reps.mozilla.org
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: pierros, Assigned: jd)

Tracking

0.2.5 - Sasak

Details

(Whiteboard: [qa-], URL)

(Reporter)

Description

6 years ago
Dev instance seems to be behind in commits:
https://reps-dev.allizom.org/media/revision_info.txt
(Assignee)

Comment 1

6 years ago
Pierros,

Getting the following error:

/usr/bin/env: node: No such file or directory
cat: /data/engagement-dev/src/reps-dev.allizom.org/remo/media/css/remo/app.less.css: No such file or directory

ls -al /data/engagement-dev/src/reps-dev.allizom.org/remo/media/css/remo/app.less.css
ls: cannot access /data/engagement-dev/src/reps-dev.allizom.org/remo/media/css/remo/app.less.css: No such file or directory

It looks like this file is non-existent, that cat error is common when compressing assets and a module is empty.

FYI there is a file in that directory named 'app.less' so perhaps it is just missing the '.css' but I am just guessing at that.

Let me know if I can provide any additional information or when you want me to try a manual update again.

Cheers
Thanks for looking into this Jason.

The problem is caused by the missing 'node' executable. Less compiler, lessc, requires node.js to compile less stylesheets to css stylesheets. Bug 754788 should provide a working lessc executable.
(Assignee)

Comment 3

6 years ago
Giorgos,

I had to switch some packages around and create some symlinks but lessc is working now and the dev site is updating again.

Please let me know if there are additional issues.

Regards
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Please add QA repro steps or mark as [qa-], thanks.
Closed as [qa-]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.