Can't sync Beta if I've already synced in Aurora

RESOLVED WORKSFORME

Status

()

Firefox for Android
Android Sync
P5
normal
RESOLVED WORKSFORME
6 years ago
8 months ago

People

(Reporter: Carmen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Engagement][User Engagement])

(Reporter)

Description

6 years ago
Web page or screen you were on when you saw the issue: 

Firefox Mobile Beta Build
Samsung Galaxy Nexus

Steps to reproduce:
1. Already synced in Aurora - works fine
2. Downloaded Beta - won't sync tabs
3. Spoke with the #mobile folks on IRC, and found out that you can only Sync one build. I understand that you guys know about this, but if we have a bunch of folks downloading Beta, and then ask them to upgrade to the GA, we're going to have a lot of bad juju out there about Sync not working. Or, if we're asking people to test more than one version. . . Just think it's bad PR
4. Is support working on an article to detail this?
5. Can we put something in-product? (Looks like you have another version Synced, here's how to sync this version?)
6. I've tried to turn off sync in Aurora and turn it on in Beta, but for the life of me, I can't get it to work. Want to put steps in the bug so I can test Sync in Beta?

What you expected: 

Crash report ID (if applicable):

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: General → Android Sync
OS: Mac OS X → Android
Product: Fennec Native → Mozilla Services
QA Contact: general → android-sync
Hardware: x86 → ARM
Resolution: --- → DUPLICATE
Version: Trunk → unspecified
Duplicate of bug: 753002
Actually, re-opening to get some other feedback on your questions. But yes, this is currently technically possible: see Richard's link in bug 753002
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to Carmen from comment #0)

> 3. Spoke with the #mobile folks on IRC, and found out that you can only Sync
> one build. I understand that you guys know about this, but if we have a
> bunch of folks downloading Beta, and then ask them to upgrade to the GA,
> we're going to have a lot of bad juju out there about Sync not working. Or,
> if we're asking people to test more than one version. . . Just think it's
> bad PR

Unfortunately, yes. If there was a good solution for this, we'd have already built and shipped it.

All we can really do is hope that most people don't try to do this.

> 4. Is support working on an article to detail this?

Over to Ally for the current state of this. We have docs, but I don't know if they're on SuMo (which tends not to support betas).

> 5. Can we put something in-product? (Looks like you have another version
> Synced, here's how to sync this version?)

Eventually; couldn't do this for the beta due to string freeze.

I'd much rather fix the actual problem, though.

> 6. I've tried to turn off sync in Aurora and turn it on in Beta, but for the
> life of me, I can't get it to work. Want to put steps in the bug so I can
> test Sync in Beta?

You can't; Android just doesn't work that way. An app "owns" an account, and you need to uninstall for ownership to change.

This is not just a matter of you being able to sync one at a time; that'd be easy. It's that Sync cannot function with more than one version of Firefox installed: you can't run setup, and only a product that's already been set up will be able to sync. The entire configuration is unsupported.
(Reporter)

Comment 4

6 years ago
(In reply to Richard Newman [:rnewman] from comment #3)
> (In reply to Carmen from comment #0)
> 
> > 3. Spoke with the #mobile folks on IRC, and found out that you can only Sync
> > one build. I understand that you guys know about this, but if we have a
> > bunch of folks downloading Beta, and then ask them to upgrade to the GA,
> > we're going to have a lot of bad juju out there about Sync not working. Or,
> > if we're asking people to test more than one version. . . Just think it's
> > bad PR
> 
> Unfortunately, yes. If there was a good solution for this, we'd have already
> built and shipped it.
> 
> All we can really do is hope that most people don't try to do this.

I'm wondering how many people testing on Beta now will upgrade to the GA when that is released and be all "Sync doesn't work!" Only get one chance to hook 'em. :)

> 
> > 4. Is support working on an article to detail this?
> 
> Over to Ally for the current state of this. We have docs, but I don't know
> if they're on SuMo (which tends not to support betas).

I was thinking less from Aurora to Beta and more from Beta to GA
> 
> > 5. Can we put something in-product? (Looks like you have another version
> > Synced, here's how to sync this version?)
> 
> Eventually; couldn't do this for the beta due to string freeze.
> 
> I'd much rather fix the actual problem, though.

+1!
> 
> > 6. I've tried to turn off sync in Aurora and turn it on in Beta, but for the
> > life of me, I can't get it to work. Want to put steps in the bug so I can
> > test Sync in Beta?
> 
> You can't; Android just doesn't work that way. An app "owns" an account, and
> you need to uninstall for ownership to change.
> 
> This is not just a matter of you being able to sync one at a time; that'd be
> easy. It's that Sync cannot function with more than one version of Firefox
> installed: you can't run setup, and only a product that's already been set
> up will be able to sync. The entire configuration is unsupported.

So if I uninstall Aurora, I can start over with Sync on Beta?
(In reply to Carmen from comment #4)

> So if I uninstall Aurora, I can start over with Sync on Beta?

The existing Sync account should start working with Beta, yes. You might have to re-check the box in Android Settings.
Blocks: 761206
Duplicate of this bug: 767302
P5: won't be directly addressed; see Bug 761206, which will take care of this.
Priority: -- → P5
No longer blocks: 761206
Depends on: 761206
How do we feel about FIXED WORKSFORME?  Work on Bug 761206 (specifically, Bug 772645) has essentially addressed this.

We now bucket {Release, Beta}, {Aurora, Nightly}, {Developer} into separate Account types and you can Sync both versions against the same (single) Account.  This arrangement specifically handles transitioning smoothly from Beta to Release.
(Assignee)

Updated

5 years ago
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → WORKSFORME

Updated

8 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.