If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[traceback] Error: UnicodeEncodeError: 'ascii' codec can't encode characters in position 62-63: ordinal not in range(128)

VERIFIED DUPLICATE of bug 748057

Status

Participation Infrastructure
Phonebook
VERIFIED DUPLICATE of bug 748057
5 years ago
5 years ago

People

(Reporter: mbrandt, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
Traceback (most recent call last):

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/views/decorators/cache.py", line 88, in _wrapped_view_func
   response = view_func(request, *args, **kwargs)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/contrib/auth/decorators.py", line 19, in _wrapped_view
   return view_func(request, *args, **kwargs)

 File "/data/www/mozillians.org/mozillians/apps/phonebook/views.py", line 71, in edit_profile
   form.save(request)

 File "/data/www/mozillians.org/mozillians/apps/phonebook/forms.py", line 173, in save
   super(ProfileForm, self).save(request.user)

 File "/data/www/mozillians.org/mozillians/apps/phonebook/forms.py", line 99, in save
   super(forms.ModelForm, self).save()

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/forms/models.py", line 363, in save
   fail_message, commit, construct=False)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/forms/models.py", line 85, in save_instance
   instance.save()

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/db/models/base.py", line 463, in save
   self.save_base(using=using, force_insert=force_insert, force_update=force_update)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/db/models/base.py", line 528, in save_base
   values = [(f, None, (raw and getattr(self, f.attname) or f.pre_save(self, False))) for f in non_pks]

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/db/models/fields/files.py", line 253, in pre_save
   file.save(file.name, file, save=False)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/db/models/fields/files.py", line 90, in save
   self.name = self.storage.save(name, content)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/files/storage.py", line 48, in save
   name = self.get_available_name(name)

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/files/storage.py", line 74, in get_available_name
   while self.exists(name):

 File "/data/www/mozillians.org/mozillians/vendor/src/django/django/core/files/storage.py", line 233, in exists
   return os.path.exists(self.path(name))

 File "/usr/lib64/python2.6/genericpath.py", line 18, in exists
   st = os.stat(path)

UnicodeEncodeError: 'ascii' codec can't encode characters in position 62-63: ordinal not in range(128)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748057
(Reporter)

Comment 2

5 years ago
Verified duplicate - thanks jsocol. I wasn't sure if the two bugs were related.
Status: RESOLVED → VERIFIED
(In reply to comment #2)
> Verified duplicate - thanks jsocol. I wasn't sure if the two bugs were related.

We need Sentry! Then we'll just get pings about new stack traces.
(Reporter)

Comment 4

5 years ago
(In reply to James Socol [:jsocol, :james] from comment #3)
> We need Sentry! Then we'll just get pings about new stack traces.

Ooh .. shiny new toy. +1
You need to log in before you can comment on or make changes to this bug.