Last Comment Bug 755902 - crash in nsDOMWindowUtils::GetFileId with nsDOMWindowUtils::getFileId(null)
: crash in nsDOMWindowUtils::GetFileId with nsDOMWindowUtils::getFileId(null)
Status: RESOLVED FIXED
: crash, testcase
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 Windows NT
: -- critical (vote)
: mozilla15
Assigned To: Jan Varga [:janv]
:
Mentors:
Depends on: 726593
Blocks: 661877
  Show dependency treegraph
 
Reported: 2012-05-16 14:13 PDT by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2012-06-03 13:28 PDT (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (uses enhanced privileges) (309 bytes, text/html)
2012-05-16 14:13 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2012-05-16 14:13:37 PDT
Created attachment 624528 [details]
testcase (uses enhanced privileges)

This bug was filed from the Socorro interface and is 
report bp-1c26e597-d903-4787-b96a-f53aa2120516 .
============================================================= 
0 	xul.dll 	nsDOMWindowUtils::GetFileId 	dom/base/nsDOMWindowUtils.cpp:2275
1 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
2 	xul.dll 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:2389
3 	xul.dll 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1541
4 	mozjs.dll 	js::types::TypeSet::addType 	js/src/jsinferinlines.h:1158
5 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2744
6 	mozjs.dll 	js::types::TypeScript::SetThis 	js/src/jsinferinlines.h:723
7 	mozjs.dll 	js::ExecuteKernel 	js/src/jsinterp.cpp:678
8 	mozjs.dll 	js::Execute 	js/src/jsinterp.cpp:720
9 	mozjs.dll 	EvaluateUCScriptForPrincipalsCommon 	js/src/jsapi.cpp:5321
10 	mozjs.dll 	JS_EvaluateUCScriptForPrincipalsVersionOrigin 	js/src/jsapi.cpp:5358
11 	xul.dll 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1485
12 	xul.dll 	nsScriptLoader::EvaluateScript 	content/base/src/nsScriptLoader.cpp:910
13 	xul.dll 	nsScriptLoader::ProcessRequest 	content/base/src/nsScriptLoader.cpp:803
14 	xul.dll 	nsScriptLoader::ProcessScriptElement 	content/base/src/nsScriptLoader.cpp:749
15 	xul.dll 	nsScriptElement::MaybeProcessScript 	content/base/src/nsScriptElement.cpp:169
Comment 1 Scoobidiver (away) 2012-05-17 01:00:18 PDT
I don't crash with the testcase.
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-05-18 10:08:09 PDT
Because it uses enhanced privileges, it's probably easiest in current builds to test it from chrome:// urls, since they removed the enhanced privs UI.
Comment 3 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-05-23 22:03:23 PDT
Jan, could you take a look?
Comment 4 Jan Varga [:janv] 2012-05-23 22:20:36 PDT
ok
Comment 5 Jan Varga [:janv] 2012-05-23 23:32:25 PDT
the patch for 726593 fixes this crash, I changed getFileId() to take a jsval
anyway, I added a new test to check the getFileId(null)
Comment 6 Jan Varga [:janv] 2012-06-03 12:55:38 PDT
fixed along with bug 726593

Note You need to log in before you can comment on or make changes to this bug.