Closed Bug 755974 Opened 8 years ago Closed 7 years ago

block AMD Radeon HD 6290/6300/6310/6320 for Direct3D 9

Categories

(Toolkit :: Blocklist Policy Requests, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox13 + verified

People

(Reporter: joe, Assigned: jorgev)

References

(Depends on 1 open bug, Blocks 5 open bugs)

Details

(Whiteboard: [gfx][qa+:marcia])

We need the blocklist created in bug 722538 duplicated, with all the contents exactly the same, except for the feature being blocked, which must be DIRECT3D_9_LAYERS .
OS: Mac OS X → Windows 7
Whiteboard: [gfx]
The block has just been added to staging.
Assignee: nobody → jorge
(In reply to Joe Drew (:JOEDREW!) from comment #0)
> We need the blocklist created in bug 722538 duplicated, with all the
> contents exactly the same, except for the feature being blocked, which must
> be DIRECT3D_9_LAYERS .

How can QA test this block? Adding qawanted to get some testing once we find out.
Keywords: qawanted
Looking at the dependency bugs, this should affect only Radeon 6 series cards?
My understanding is that this affects the integrated GPU in AMD Fusion GPUs, like the C-50.
Jorge: What is the URL for the block?
Video driver blocks don't have public URLs. You should be looking for blockID="g88" in blocklist.xml.
Here are the results of my testing on my Radeon machine that I have with an Aurora build:

-<gfxBlacklistEntry blockID="g88"> <os>WINNT 6.1</os> <vendor>0x1002</vendor> -<devices> <device>0x9802</device> <device>0x9803</device> <device>0x9803</device> <device>0x9804</device> <device>0x9805</device> <device>0x9806</device> <device>0x9807</device> </devices> <feature>DIRECT3D_9_LAYERS</feature> <featureStatus>BLOCKED_DEVICE</featureStatus> <driverVersion>1.0.0.0</driverVersion> <driverVersionComparator>GREATER_THAN_OR_EQUAL</driverVersionComparator> </gfxBlacklistEntry> </gfxItems> </blocklist>



  Graphics

        Adapter Description
        AMD Radeon HD 6310 Graphics

        Vendor ID
        0x1002

        Device ID
        0x9802

        Adapter RAM
        384

        Adapter Drivers
        aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.863.0.0

        Driver Date
        6-28-2011

        Direct2D Enabled
        Blocked for your graphics card because of unresolved driver issues.

        DirectWrite Enabled
        false (6.1.7601.17789)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (AMD Radeon HD 6310 Graphics) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)

        GPU Accelerated Windows
        0. Blocked for your graphics card because of unresolved driver issues.
OK, everything's working then.
It doesn't prove it works as it's the same about:support page as in bug 722538 comment 77 without the D3D9 blocklist.
bug 722538 comment 77 has:

        GPU Accelerated Windows
        0

Comment #8 has:

        GPU Accelerated Windows
        0. Blocked for your graphics card because of unresolved driver issues.

Is that what is supposed to be different?
I believe so.

Marcia, can you also show us the "modified preferences" section of about:support - specifically, the gfx.blacklist parts? That'll be definitive.
No longer blocks: 700288
Blocks: 700288
  Important Modified Preferences

      Name

      Value

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        1048576

        browser.places.smartBookmarksVersion
        4

        browser.startup.homepage_override.buildID
        20120521042008

        browser.startup.homepage_override.mstone
        14.0a2

        extensions.lastAppVersion
        14.0a2

        gfx.blacklist.direct2d
        4

        gfx.blacklist.layers.direct3d9
        4

        gfx.direct3d.prefer_10_1
        true

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        96716

        privacy.sanitize.migrateFx3Prefs
        true

  Graphics

        Adapter Description
        AMD Radeon HD 6310 Graphics

        Vendor ID
        0x1002

        Device ID
        0x9802

        Adapter RAM
        384

        Adapter Drivers
        aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.863.0.0

        Driver Date
        6-28-2011

        Direct2D Enabled
        Blocked for your graphics card because of unresolved driver issues.

        DirectWrite Enabled
        false (6.1.7601.17789)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (AMD Radeon HD 6310 Graphics) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)

        GPU Accelerated Windows
        0. Blocked for your graphics card because of unresolved driver issues.
        gfx.blacklist.direct2d
        4

        gfx.blacklist.layers.direct3d9
        4

These values imply that the blocklist is working correctly.
Per comment 14, removing QAWANTED as it appears the block is working. Please re-add if there is more testing desired. Adding [qa+] whiteboard tag so we can track for verification once live.
Keywords: qawanted
Whiteboard: [gfx] → [gfx][qa+]
The block has been pushed to prod now, with blockID="g95". Adding qawanted again for marcia to give it a look.
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Verified fixed in production. I tested using the latest Aurora build and confirmed that I get blockID="g95 in my blocklist file as well as:

  Important Modified Preferences

      Name

      Value

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        1048576

        browser.places.smartBookmarksVersion
        4

        browser.startup.homepage_override.buildID
        20120523042007

        browser.startup.homepage_override.mstone
        14.0a2

        extensions.lastAppVersion
        14.0a2

        gfx.blacklist.direct2d
        4

        gfx.blacklist.layers.direct3d9
        4

        gfx.direct3d.prefer_10_1
        true

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        96716

        privacy.sanitize.migrateFx3Prefs
        true

  Graphics

        Adapter Description
        AMD Radeon HD 6310 Graphics

        Vendor ID
        0x1002

        Device ID
        0x9802

        Adapter RAM
        384

        Adapter Drivers
        aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.863.0.0

        Driver Date
        6-28-2011

        Direct2D Enabled
        Blocked for your graphics card because of unresolved driver issues.

        DirectWrite Enabled
        false (6.1.7601.17789)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (AMD Radeon HD 6310 Graphics) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)

        GPU Accelerated Windows
        0. Blocked for your graphics card because of unresolved driver issues.
Status: RESOLVED → VERIFIED
Thanks Marcia, I think qawanted can be removed. Given this is being tracked for Firefox 13, can you do a quick check in Beta?
Keywords: qawanted
Per Anthony's request, I have verified this bug fixed using the latest beta, Firefox 13 Beta 6. I get the same results in about:support as Comment 18.
Thanks Marcia.
Whiteboard: [gfx][qa+] → [gfx][qa+:marcia]
Depends on: 790169
Depends on: 840161
Product: addons.mozilla.org → Toolkit
Depends on: 1335925
You need to log in before you can comment on or make changes to this bug.