erratic page movement while panning during pinch

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: luke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Normal panning now feels quite smooth and well-behaved which is great.  However, as soon as I pinch and start panning the pinched page around (i.e., moving the two pinching fingers) the page moves erratically.  I'm not sure if there is some snapping logic or if the page is somehow interfering, but it would be great if we could just turn all that stuff off and have pan-during-pinch act like pan-not-during-pinch.

(I was able to reproduce this erratic behavior on all the sites I tested.  An example is Google reader mobile.)
This is more or less by design. When you have two fingers down, you're in pinch mode, and moving both fingers is basically a pinch where you're keeping the scale the same but moving the focal point of the pinch. To the user it looks like a pan.

Having the two-finger-pan behave the same as the one-finger-pan is a hard problem, because we'd have to check to see if both fingers are moving in the same direction (i.e. use heuristics to distinguish between a two-finger-pan and a "pinch"). I feel it would very hard to get this right, and result in user frustration because we'd end up panning when they're trying adjust the zoom.

I'm inclined to mark this as a WONTFIX unless you have a compelling argument for why panning with two fingers is something that users will be doing (as opposed to just panning with one finger).
(Reporter)

Comment 2

6 years ago
I didn't mean that I want it to behave exactly like 1 finger pan; the bug is that it moves around in a stuttery, non-smooth manner.
Ah, I see. What device were you using when you saw this? We might be able to do some motion smoothing or something to make it less jittery.
(Reporter)

Comment 4

6 years ago
A stock Samsung Galaxy SII.  As an example, just go to Google reader (with a lot of entires), pinch and hold and then slowly pan it around.  Weird things happen.  Sometimes it feels like the page is "tugging" against me (the focal point of the pinch seems to move, sometimes off the content entirely).
blocking-fennec1.0: --- → ?
Is this just a digitizer precision problem?  Often when you have more than one finger down precision goes a good bit down..
(Reporter)

Comment 6

6 years ago
Hah, you're right!  I played with Google maps on the same device and got the same weirdness.
(Reporter)

Comment 7

6 years ago
I'm happy to resolve invalid unless someone thinks Fennec can do something better.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
blocking-fennec1.0: ? → ---
You need to log in before you can comment on or make changes to this bug.