New Imap folders ("mailboxes") on server are not immediately shown in TB

UNCONFIRMED
Unassigned

Status

Thunderbird
Folder and Message Lists
UNCONFIRMED
6 years ago
6 years ago

People

(Reporter: Chris Blokland, Unassigned)

Tracking

11 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/11.10 Chromium/18.0.1025.168 Chrome/18.0.1025.168 Safari/535.19

Steps to reproduce:

Received mail marked as spam (serverside with spam assassin)


Actual results:

Folder Spam wich was created serverside did not show up in the list of mailboxes


Expected results:

The automatic created mailbox Spam should have been listed automatically.
After restarting the client the mailbox was popping up.

Strange thing is that the mailbox was listed at the list of subscriptions for the account and it was checked as well (that happens serverside).

Comment 1

6 years ago
(In reply to Chris Blokland from comment #0)
Are you using gmail or an ordinary IMAP server?
(In reply to Chris Blokland from comment #0)
> Expected results:
> The automatic created mailbox Spam should have been listed automatically.

As new mail is not automatically notified to IMAP client by IMAP server(except when connection is established and Mbox is selected at the connection and IDLE is used), a newly created IMAP folder at IMAP server is not automatically notified to IMAP client(Tb in your case) by IMAP server.
Are you requesting featur such as "periodical new IMAP folder check" like new mail check interval?

To force check of new or deleted IMAP folder, one of two action is needed.
 (i)  LIST */* for all existent IMAP folders
 (ii) LSUB */* for all subscribed IMAP folders
Number of existent IMAP folders >= Number of subscribed IMAP folders <= .
In case of Number of existent IMAP folders is far larger than Number of subscribed IMAP folders, Tb has mode of "Show subscribed folders only"(Server Settings/Advanced) for peformance reason. Tb's behavior depends on this setting. 
And, also for performane reason, Tb doesn't use LIST */* for all folders. Tb uses LIST % and LIST %/%(one level deeper folder).

Do you check/enable "Show subscribed only"? or uncheck/disble it?

> Strange thing is that the mailbox was listed at the list of subscriptions for the account and it was checked as well

When you saw "not shown at folder pane" first time and before restart of Tb?
Or after you restarted Tb?
Summary: Not all mailboxes are listed → New Imap folders ("mailboxes") on server are not immediately shown in TB
You need to log in before you can comment on or make changes to this bug.