Implement Do Not Track redesign

RESOLVED FIXED

Status

www.mozilla.org
General
P1
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: kohei, Assigned: sgarrity)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

6 years ago
Depends on: 756358
(Reporter)

Updated

6 years ago
Depends on: 756359
(Reporter)

Updated

6 years ago
Depends on: 756361
(Reporter)

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 1

6 years ago
We've translated the DNT Guide into Japanese. We also would like to localize dnt.mozilla.org but the content is not enough and design is obsolete. So I've filed some bugs to make things better.

Updated

6 years ago
Priority: -- → P1
Target Milestone: --- → 2.7
Current DNT product page needs updated designs.

Link to PSD here:
http://cl.ly/280X0n2o0d1T0x1c473E

Dependencies such as revising content, localization, and moving to moz.org/dnt shouldn't block us from moving forward with implementing the designs.
(Reporter)

Comment 3

6 years ago
Removing the design bug from the dependency list.
No longer depends on: 756222
Whiteboard: [good first bug]
Silver Orange is going to take this. Steven says it would be easier to port this over to Bedrock now. It'll live at mozilla.org/dnt
Assignee: nobody → steven

Comment 5

6 years ago
Wouldn't it make sense to put this page in the /privacy hierarchy? I'd defer to :geekboy on this, since he owns the current dnt page.
No, I think putting it in /dnt is fine.  DNT is product-focused and not "what we do"-focused, which is the concentration at /privacy.
(Assignee)

Updated

6 years ago
Depends on: 758330
(Assignee)

Comment 9

6 years ago
This page is setup in dev now, visible: http://www-dev.allizom.org/b/en-US/dnt/

We're blocked on Bug 758330 from IT, but it can be reviewed for content/design in the mean time.

Comment 10

6 years ago
Created attachment 627363 [details]
DNT page - tweaks

You guys rock. Thanks for being so responsive and updating this page. I'm attaching a side by side (dev page on right, psd on left) with minor revisions/comments. Let me know if you have any questions. Thanks! L
(Assignee)

Comment 11

6 years ago
(In reply to Lee Tom from comment #10)
> You guys rock. Thanks for being so responsive and updating this page. I'm
> attaching a side by side (dev page on right, psd on left) with minor
> revisions/comments. Let me know if you have any questions. Thanks! L

Great detailed feedback - will fix up. The logo/wordmark change - that is coming from the Firefox template used on the other /firefox pages (/firefox/fx/, /firefox/features/, etc.). Should they all change?
(Reporter)

Updated

6 years ago
Depends on: 759228

Comment 13

6 years ago
Looks good to me -- I echo Lee's comments and tweaks in Comment #10.  Lets be sure to follow the PSD as designed as much as possible. Thanks everyone.
(Assignee)

Comment 14

6 years ago
This page is setup in dev and ready for QA: http://www-dev.allizom.org/b/en-US/dnt/
Keywords: qawanted
Whiteboard: [good first bug]
(Reporter)

Comment 15

6 years ago
Hey, the content has not been updated yet. See the dependency bugs.
(Assignee)

Comment 16

6 years ago
(In reply to Kohei Yoshino from comment #15)
> Hey, the content has not been updated yet. See the dependency bugs.

Kohei, I presumed that more time/work was needed on the content. Since this page includes everything from dnt.mozilla.org, but with the update visual style, I don't think we'd need to block on any new content changes.
(Reporter)

Comment 17

6 years ago
This bug is intended to revise the content. I've filed this bug. The design work is Bug 756222 and the migration work is Bug 756358.
(Reporter)

Comment 18

6 years ago
And you know this is a tracking/meta bug.
(Reporter)

Comment 19

6 years ago
Somehow you guys might misunderstand this bug as the implementation work for Bug 756222...
(Reporter)

Updated

6 years ago
No longer depends on: 749725
(Reporter)

Updated

6 years ago
No longer depends on: 756359
(Reporter)

Updated

6 years ago
No longer depends on: 759228
(Reporter)

Updated

6 years ago
No longer depends on: 756361
(Reporter)

Updated

6 years ago
Depends on: 756222
Keywords: meta
Summary: Create new Do Not Track portal page → Implement Do Not Track redesign
(Assignee)

Comment 20

6 years ago
(In reply to Kohei Yoshino from comment #19)
> Somehow you guys might misunderstand this bug as the implementation work for
> Bug 756222...

You're right - sorry for the confusion there.
(Reporter)

Comment 21

6 years ago
That's it. The content overhaul is Bug 756361 as noted above. Thanks.
(Assignee)

Updated

6 years ago
No longer depends on: 756358, 758330, 756222
Keywords: qawanted
(Assignee)

Comment 22

6 years ago
I've filed bug 760194 to track the implementation of the design updates from Bug 756222.

Comment 23

6 years ago
Commit pushed to dev at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/9eab150a4fe96a199e8ce334b3678d8cc5147b95
Merge pull request #142 from sgarrity/bug-756356-dnt2

Bug 756356 dnt2
(Assignee)

Updated

6 years ago
Target Milestone: 2.7 → ---
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
This was pushed live a while back.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Duplicate of this bug: 661925
You need to log in before you can comment on or make changes to this bug.