Attachment reminder button text/captions should be more self-explaining

RESOLVED WONTFIX

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: nottheoilrig, Unassigned)

Tracking

(Depends on: 1 bug)

11 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725



Actual results:

The attachment reminder notification reads like a conversation: "Did you forget to add an attachment?" "Oh, yes I did" "No, send now"

I don't like how the meaning of the buttons depends on reading the message, so if you're just looking at the buttons, it takes a sec to figure out what "yes" and "no" will actually do


Expected results:

I would prefer buttons that say explicitly what they will do, instead of needing the context of the notification message, e.g. "Stop sending and let me add an attachment" "Continue sending, as is, without any attachments" (probably better text can  be invented, but you get the idea)

Updated

6 years ago
Severity: normal → enhancement

Comment 1

6 years ago
It's one of the nicest little conversations you can have with TB... ;)

I don't see a problem here, but we could try reporter's idea to make the button captions more self-explaining. However, Jack (reporter), long button texts are hard to parse and look odd, so we would be "jumping out of the frying pan into the fire". If anything, we need short and concise button captions. More something like

a) [Yes, add attachments now] [No, send without attachments]

That's clearer, but also longer and not very easy to parse because both captions contain the word "attachments" so again we have to look very closely which is which. Perhaps this?

b) [Yes, add attachments now] [No, send now]

Perhaps that brings out the alternative actions more clearly:
- add attachments first (before sending) or
- send immediately (obviously without attachments, otherwise there would be no reminder!)

Comment 2

6 years ago
(In reply to Thomas D. from comment #1)
> b) [Yes, add attachments now] [No, send now]

Having "now" in both button captions is not ideal, either, so maybe:

c) [Yes, add attachments...] [No, send now]

BUT that's not very true either because clicking Yes just cancels sending, but correctly doesn't open attachment dialogue (as we have several options there, attach file, attach url, attach filelink...)

So I'm not sure, perhaps the nice little dialogue we currently have is just right:

Current dialogue (TB12.0.1)

=Attachment reminder=
Did you forget to add an attachment?
[No, send now] [Oh, I did]

I like the choice between "No" and "Oh", feels natural and has the right emotions... ;)

Updated

6 years ago
Summary: Attachment reminder button text → Attachment reminder button text/captions should be more self-explaining

Updated

6 years ago
OS: Linux → All
Hardware: x86 → All

Comment 3

6 years ago
Keep in mind that before you even get to that dialog, the reminder bar at the bottom of the composition window should show up with options "Add attachment" versus "Remind me later", thus the "Did you forget?" question has to be seen in that context (unless you missed/ignored the dialog). On the other hand, it's not obvious what the "Oh, I did!" button does (basically just cancelling the send process thus you can add the attachment), so that may be a ux-discovery issue.

Comment 4

5 years ago
(In reply to Thomas D. from comment #2)
> (In reply to Thomas D. from comment #1)
> c) [Yes, add attachments...] [No, send now]
> 
> BUT that's not very true either because clicking Yes just cancels sending,
> but correctly doesn't open attachment dialogue (as we have several options
> there, attach file, attach url, attach filelink...)

xref bug 516957
See Also: → bug 516957

Comment 5

5 years ago
Actually *depends* on 516957 which, if implemented, would need to be considered when looking for new caption for "Oh, I did!" button.
Depends on: 516957
See Also: bug 516957

Comment 6

4 years ago
I'm marking this WONTFIX. It would have to be pretty long verbiage to explain what it does. And what problem does it solve? If you forgot to add an attachment, surely you hit "Oh, I did!" OR just press ESC, both will let you add the attachment. ONLY if you hit "No, Send Now" would there be a problem, but that's more of a PEBKAC problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
See Also: → bug 521158
You need to log in before you can comment on or make changes to this bug.