Last Comment Bug 756579 - nsXBLBinding::GetInsertionPointsFor is now infallible
: nsXBLBinding::GetInsertionPointsFor is now infallible
Status: RESOLVED FIXED
[mentor=bsmedberg][lang=c++]
:
Product: Core
Classification: Components
Component: XBL (show other bugs)
: unspecified
: All All
: -- trivial (vote)
: mozilla16
Assigned To: Jignesh Kakadiya [:jhk]
:
Mentors:
Depends on: 734847
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 13:10 PDT by Benjamin Smedberg [:bsmedberg]
Modified: 2012-06-09 19:48 PDT (History)
7 users (show)
dzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch(v1) (2.42 KB, patch)
2012-05-23 06:34 PDT, Jignesh Kakadiya [:jhk]
benjamin: review+
Details | Diff | Review

Description Benjamin Smedberg [:bsmedberg] 2012-05-18 13:10:30 PDT
nsXBLBinding::GetInsertionPointsFor is now infallible (because hashtables are infallible) and we should make it return "void".
Comment 2 Xi Yang 2012-05-22 10:56:54 PDT
Hi, I need some more tips to help.
Comment 3 Benjamin Smedberg [:bsmedberg] 2012-05-22 13:09:44 PDT
The return value of the function (http://hg.mozilla.org/mozilla-central/annotate/c20d415ef1b5/content/xbl/src/nsXBLBinding.cpp#l1401) should be 'void' instead of nsresult, and the callers need to be updated to not error-check it.
Comment 4 Jignesh Kakadiya [:jhk] 2012-05-23 06:34:31 PDT
Created attachment 626416 [details] [diff] [review]
Patch(v1)
Comment 5 Benjamin Smedberg [:bsmedberg] 2012-05-24 06:01:14 PDT
Comment on attachment 626416 [details] [diff] [review]
Patch(v1)

Heh, nobody used the return value anyway? awesome ;-)
Comment 6 David Zbarsky (:dzbarsky) 2012-06-09 15:21:59 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/c3f52520b774
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-06-09 19:48:47 PDT
https://hg.mozilla.org/mozilla-central/rev/c3f52520b774

Note You need to log in before you can comment on or make changes to this bug.