bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Robocop: unable to copy to /sdcard/robotium.config using dmADB

RESOLVED DUPLICATE of bug 767449

Status

Testing
General
RESOLVED DUPLICATE of bug 767449
6 years ago
6 years ago

People

(Reporter: gbrown, Assigned: gbrown)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
On my Galaxy Nexus, robocop-via-dmADB tests fail because robotium.config and fennec_ids.txt cannot be copied to /sdcard. 

 - although the phone is rooted and devicemanagerADB knows that root is available, pushFile uses run-as with cp for the push; this is intentional: https://bugzilla.mozilla.org/show_bug.cgi?id=720806#c9
 - org.mozilla.fennec_<user> is not part of the sdcard_rw group, so cannot write to /sdcard

Part of the problem is that robocop is writing these files to /sdcard, rather than using the test root (/data/local/tests is writable, but /sdcard/tests is no better than /sdcard). /sdcard is hard coded because these files are accessed by Java code that has no idea of the test root, as seen by host python scripts.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 767449
You need to log in before you can comment on or make changes to this bug.