Old version of beta being served from http://www.mozilla.org/en-US/firefox/channel/

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: marcia, Assigned: jlong)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When testing today, I noticed that http://www.mozilla.org/en-US/firefox/channel/ is serving up Beta2 when Beta 3 has already shipped. I have observed this is on both Mac and Windows 8.

Comment 1

7 years ago
Assigning to James. We're all up to date on the product-details side, so it must have something to do with Bedrock. Last I heard, we were trying to get a cron job setup to perform this step every X minutes.
Assignee: nobody → jlong

Comment 2

7 years ago
I had noticed something like that to Alex after being pointed to that on IRC. In that case it was the download link at http://www.mozilla.org/en-US/firefox/beta/ which now correctly has beta 4. Don't we have some common source where all those can pull the info on current beta from?

Updated

7 years ago
Duplicate of this bug: 756727
(Assignee)

Comment 4

7 years ago
Alex, I've updated product details and committed it to master. IT needs to push this out now. Not sure if you want to try to make that happen earlier than Monday, but I can ping them on Monday to do it.
(Assignee)

Comment 5

7 years ago
There is a push happening tomorrow, and I vote to just wait until then. I will update the product-details one more time tomorrow to catch anything else. The push will happen early in the day.

Comment 6

7 years ago
(In reply to James Long (:jlongster) from comment #5)
> There is a push happening tomorrow, and I vote to just wait until then. I
> will update the product-details one more time tomorrow to catch anything
> else. The push will happen early in the day.

Is it difficult to push this out today? My strong preference would be to start vending these out as soon as possible.

What's the long term solution here? We put out a new beta weekly.
(Assignee)

Comment 7

7 years ago
We actually moved the pushed to 4:30 PM EST today, so we should be good.

When does the beta go out during the week? We push every Tuesday. If we need to automatically update product-details somehow, we'll need to think through how to do that.
(Assignee)

Comment 8

7 years ago
This has been fixed, Alex please follow up with me and we can figure a general solution for this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.