crash in mozilla::AndroidLayerRendererFrame::DrawBackground @ libpvrANDROID_WSEGL

RESOLVED DUPLICATE of bug 752368

Status

()

Core
Widget: Android
--
critical
RESOLVED DUPLICATE of bug 752368
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash})

14 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash][gfx], crash signature)

(Reporter)

Description

6 years ago
It seems to be different from bug 744286.

Signature 	libpvrANDROID_WSEGL.so@0x7fc More Reports Search
UUID	651785f3-b9a1-46db-b662-ad0352120518
Date Processed	2012-05-18 21:34:35
Uptime	9
Install Age	1.5 minutes since version was first installed.
Install Time	2012-05-18 21:32:39
Product	FennecAndroid
Version	14.0
Build ID	20120515171426
Release Channel	beta
OS	Linux
OS Version	0.0.0 Linux 2.6.32.9-gb08c3c8 #1 PREEMPT Fri Jun 3 11:40:33 CST 2011 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0x20
App Notes 	
AdapterVendorID: mapphone_umts, AdapterDeviceID: MB525.
AdapterDescription: 'Model: 'MB525', Product: 'libra_jordan', Manufacturer: 'motorola', Hardware: 'mapphone_umts''.
motorola MB525
MOTO/libra_jordan/jordan:2.3.7/MIUI/2.4.13:userdebug/test-keys
EMCheckCompatibility	True

Frame 	Module 	Signature 	Source
0 	libpvrANDROID_WSEGL.so 	libpvrANDROID_WSEGL.so@0x7fc 	
1 	libdvm.so 	dexDataMapAlloc 	
2 	libIMGegl.so 	KEGLGetDrawableParameters 	
3 	libGLESv2_POWERVR_SGX530_125.so 	libGLESv2_POWERVR_SGX530_125.so@0x162f2 	
4 	libdvm.so 	dexDataMapAlloc 	
5 	libdvm.so 	dexDataMapAlloc 	
6 	dalvik-heap (deleted) 	dalvik-heap @0x245dcac 	
7 	libc.so 	libc.so@0xfe72 	
8 	libIMGegl.so 	__aeabi_fcmpge 	
9 	libGLESv2_POWERVR_SGX530_125.so 	libGLESv2_POWERVR_SGX530_125.so@0x129de 	
10 	libdvm.so 	dexDataMapAlloc 	
11 	libGLESv2_POWERVR_SGX530_125.so 	libGLESv2_POWERVR_SGX530_125.so@0x6502 	
12 	libandroid_runtime.so 	libandroid_runtime.so@0x3cf0f 	
13 	libdvm.so 	dvmPlatformInvoke 	
14 	libdvm.so 	dvmCallJNIMethod_staticNoRef 	
15 	libdvm.so 	dvmAsmSisterStart 	
16 	libdvm.so 	dvmMterpStd 	
17 	libdvm.so 	dvmInterpret 	
18 	libdvm.so 	dvmCallMethodV 	
19 	libdvm.so 	JNI_CreateJavaVM 	
20 	libxul.so 	_JNIEnv::CallVoidMethod 	jni.h:631
21 	libxul.so 	mozilla::AndroidLayerRendererFrame::DrawBackground 	widget/android/AndroidJavaWrappers.cpp:850
22 	libxul.so 	nsWindow::DrawWindowUnderlay 	widget/android/nsWindow.cpp:2247
23 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	gfx/layers/opengl/LayerManagerOGL.cpp:829
24 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:468
25 	libxul.so 	mozilla::layers::LayerManagerOGL::EndEmptyTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:441
26 	libxul.so 	mozilla::layers::CompositorParent::Composite 	gfx/layers/ipc/CompositorParent.cpp:231
27 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
28 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
29 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
30 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
31 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:23
32 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
33 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
34 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156
35 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:26
36 	libc.so 	libc.so@0x11ec2 	
37 	libc.so 	libc.so@0x11a96

More reports at:
https://crash-stats.mozilla.com/report/list?signature=libpvrANDROID_WSEGL.so%400x7fc
(Reporter)

Comment 1

6 years ago
There are no crashes after 14.0a2/20120518. It's probably a dupe of bug 752368.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752368
You need to log in before you can comment on or make changes to this bug.