Closing a background tab in tablet mode changes the selected tab.

RESOLVED FIXED in Firefox 15

Status

Fennec Graveyard
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({regression})

Firefox 10
Firefox 15
regression

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 625281 [details] [diff] [review]
patch

Steps to reproduce (in XUL Fennec, landscape tablet mode):
1. Open three tabs.
2. While tab #3 is selected, close tab #1.

Expected results: Tab #1 is closed; tab #3 is selected.
Actual results:   Tab #1 is closed; tab #2 is selected.

This happens because the click on the close button propagates up to the tab and selects it before closing it.

This is a regression in Firefox 10.  It might be caused by bug 660887, though I haven't verified that.  It's pretty annoying and the fix is incredibly simple, so I'd like to get it into beta and even ESR10 if possible.  It's an incredibly low-risk fix that only touches XUL Fennec.  It wasn't caught sooner because we stopped doing QA and dogfooding of XUL Fennec shortly after the 10.0 release.
Attachment #625281 - Flags: review?(mark.finkle)
Attachment #625281 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 1

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9356dc589279
Target Milestone: --- → Firefox 15
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/mozilla-central/rev/9356dc589279
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox15: affected → fixed
Resolution: --- → FIXED
(Assignee)

Comment 3

5 years ago
Comment on attachment 625281 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 660887

User impact if declined: Closing tabs can result in unpredictable behavior.

Testing completed (on m-c, etc.): Landed on m-c on 5/19 and passes existing automated tests; but our real test population for XUL Fennec is only on the beta channel.

Risk to taking this patch (and alternatives if risky): Very low-risk one-line patch that touches XUL Fennec only, and fixes a user-facing regression in Fx10.

String or UUID changes made by this patch: None
Attachment #625281 - Flags: approval-mozilla-beta?
Attachment #625281 - Flags: approval-mozilla-aurora?

Comment 4

5 years ago
Comment on attachment 625281 [details] [diff] [review]
patch

[Triage Comment]
Approved for all branches since this patch only affects XF, although we likely won't be shipping XF13 or XF14 products.
Attachment #625281 - Flags: approval-mozilla-esr10+
Attachment #625281 - Flags: approval-mozilla-beta?
Attachment #625281 - Flags: approval-mozilla-beta+
Attachment #625281 - Flags: approval-mozilla-aurora?
Attachment #625281 - Flags: approval-mozilla-aurora+

Updated

5 years ago
tracking-firefox-esr10: ? → 13+
status-firefox-esr10: --- → affected
tracking-firefox13: --- → +
tracking-firefox14: --- → +
tracking-firefox15: --- → +
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/86ebc83b9671
https://hg.mozilla.org/releases/mozilla-beta/rev/42f99a6eeb62

I'll wait until this has baked on beta before I land it on ESR10.

Alex, do I need to land on a relbranch to hit the next XUL Fennec 13 beta build?
status-firefox13: affected → fixed
status-firefox14: affected → fixed

Comment 6

5 years ago
(In reply to Matt Brubeck (:mbrubeck) from comment #5)
> https://hg.mozilla.org/releases/mozilla-aurora/rev/86ebc83b9671
> https://hg.mozilla.org/releases/mozilla-beta/rev/42f99a6eeb62
> 
> I'll wait until this has baked on beta before I land it on ESR10.
> 
> Alex, do I need to land on a relbranch to hit the next XUL Fennec 13 beta
> build?

Yes, but we don't have another beta build at this point prior to XF10.0.5's release. Let's instead wait till the ESR released alongside 14+ (if there is one for XF), since it sounds like we're concerned about risk at this point.
tracking-firefox-esr10: 13+ → 14+
Attachment #625281 - Flags: approval-mozilla-esr10+ → approval-mozilla-esr10?
Verified Fixed on 14.0b6 XF for tablets
status-firefox14: fixed → verified
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/releases/mozilla-esr10/rev/629da13f0edf
status-firefox-esr10: affected → fixed
Comment on attachment 625281 [details] [diff] [review]
patch

Belated approval for ESR :)
Attachment #625281 - Flags: approval-mozilla-esr10? → approval-mozilla-esr10+
You need to log in before you can comment on or make changes to this bug.