Some web pages do not display full content in Firefox 12

RESOLVED DUPLICATE of bug 290146

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 290146
5 years ago
5 years ago

People

(Reporter: retierney@cox.net, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Opened web page http://www.gupetition.org/ on Windows 7 64 bit laptop running Firefox 12.


Actual results:

The body of the web page does not display. This happens to other sites also. It works fine in Internet Explorer 9. I inspected the element and clicked on the HTTP button. All of the content is there, it simply doesn't display.


Expected results:

The body text should have displayed.
(Reporter)

Comment 1

5 years ago
Running Windows 7 Home Premium...
I see this on Mac as well using both the latest nightly and latest Beta. The same site does show the rest of the content on Chrome.
Component: Untriaged → Layout
Product: Firefox → Core
QA Contact: untriaged → layout

Comment 3

5 years ago
The main content is off-screen on the right for some reason, when I view that page.

Comment 4

5 years ago
It's something to do with the floating header not being cleared. If you open the Web console (Ctrl+Shift+K) on that page and enter

document.getElementById("main").style.clear="both"

that seems to fix it. I don't know why it displays differently in Firefox than other browsers though.

Comment 5

5 years ago
Created attachment 625344 [details]
reduced html

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: Layout → Layout: Floats
Keywords: testcase
OS: Windows 7 → All
QA Contact: layout → layout.floats
Hardware: x86_64 → All
Resolution: --- → DUPLICATE
Version: 12 Branch → unspecified
Duplicate of bug: 290146
You need to log in before you can comment on or make changes to this bug.