If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Re-enable addon-options-displayed notification in Fennec

RESOLVED FIXED in Firefox 14

Status

()

Firefox for Android
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: wesj, Assigned: wesj)

Tracking

Trunk
Firefox 15
Points:
---

Firefox Tracking Flags

(firefox14 fixed, blocking-fennec1.0 soft)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

5 years ago
This is fired when options for an addon are shown. The code is commented out. We should re-enable it for addon authors.
(Assignee)

Comment 1

5 years ago
Created attachment 625301 [details] [diff] [review]
Patch

Un-comments these lines.
Assignee: nobody → wjohnston
Attachment #625301 - Flags: review?(mark.finkle)
(Assignee)

Comment 2

5 years ago
Created attachment 625305 [details] [diff] [review]
Patch 2/2 - Deleted table

Whoops. Need to test this a bit more first, but this is better...
Attachment #625301 - Attachment is obsolete: true
Attachment #625301 - Flags: review?(mark.finkle)
(Assignee)

Comment 3

5 years ago
Created attachment 625324 [details] [diff] [review]
Patch 3

Tested with one of my addons.
Attachment #625305 - Attachment is obsolete: true
Attachment #625324 - Flags: review?(mark.finkle)
(Assignee)

Comment 4

5 years ago
Crap. Please ignore the dump(JSON.stringify(list)); piece. Stupid hg.
(Assignee)

Comment 5

5 years ago
Created attachment 625325 [details] [diff] [review]
Patch

Trying to rush at the end of the day is not working for me. This is the patch I meant!
Attachment #625324 - Attachment is obsolete: true
Attachment #625324 - Flags: review?(mark.finkle)
Attachment #625325 - Flags: review?(mark.finkle)
Attachment #625325 - Flags: review?(mark.finkle) → review+
Might be worth a soft blocker, since this could affect add-on devs.
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → soft
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/cd8973ac8ba6

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/cd8973ac8ba6
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
(Assignee)

Comment 9

5 years ago
Comment on attachment 625325 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Original Addons patch for mobile
User impact if declined: More difficult for addon authors to use our already limited UI options
Testing completed (on m-c, etc.): Landed on 5/21
Risk to taking this patch (and alternatives if risky): Very low risk. Mobile only. Addons Manager only. Only runs when opening up options pane.
String or UUID changes made by this patch: None
Attachment #625325 - Flags: approval-mozilla-aurora?
Attachment #625325 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Is this ready to push to Aurora?
status-firefox14: --- → affected
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/840623d838d9
status-firefox14: affected → fixed
You need to log in before you can comment on or make changes to this bug.