Malformed PDF: Unknown command " "

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: mats, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STEPS TO REPRODUCE
1. load http://samples.jbpub.com/9781449648206/61417_CH03_Smith.pdf

ACTUAL RESULTS
PDF.JS Build: 2e92c0e
Message: Malformed PDF: Unknown command ""
Stack: error@blob:d0ead523-8f91-4db7-a43c-4a9cdb2cd708:927
malformed@blob:d0ead523-8f91-4db7-a43c-4a9cdb2cd708:936
assertWellFormed@blob:d0ead523-8f91-4db7-a43c-4a9cdb2cd708:948
PartialEvaluator_getOperatorList@blob:d0ead523-8f91-4db7-a43c-4a9cdb2cd708:12776
PartialEvaluator_getOperatorList@blob:d0ead523-8f91-4db7-a43c-4a9cdb2cd708:12840
Page_getOperatorList@blob:d0ead523-8f91-4db7-a43c-4a9cdb2cd708:236
wphSetupPageRequest@blob:d0ead523-8f91-4db7-a43c-4a9cdb2cd708:28932
messageHandlerComObjOnMessage@blob:d0ead523-8f91-4db7-a43c-4a9cdb2cd708:28866

PLATFORMS AND BUILDS TESTED
Bug occurs in Nightly:
Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Built from http://hg.mozilla.org/mozilla-central/rev/c00a9c1940c5

Updated

6 years ago
Duplicate of this bug: 739183

Updated

6 years ago
Whiteboard: [pdfjs-c-rendering]
Created attachment 711327 [details]
screenshot

I don't get that message but the PDF is not displayed correctly. With latest Nightly I get the display from the attached screenshot, while on latest Beta I get only blank pages.
Still many warnings displayed in Web Console, but the display was improved (probably because of #2936).
Looks fine now, still some warnings, but original issue is fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.