Last Comment Bug 756745 - xptcall fails to build with mipsel-linux-android target
: xptcall fails to build with mipsel-linux-android target
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: Other Android
: -- normal (vote)
: mozilla15
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: android-mips
  Show dependency treegraph
 
Reported: 2012-05-19 01:34 PDT by Mike Hommey [:glandium]
Modified: 2012-05-25 08:24 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use CPPFLAGS for defines and forced includes, and add them to ASFLAGS (18.10 KB, patch)
2012-05-19 09:04 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Use CPPFLAGS for defines and forced includes, and add them to ASFLAGS (16.27 KB, patch)
2012-05-19 09:05 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Use the "right" headers for mips xptc assembly on android (2.09 KB, patch)
2012-05-19 09:07 PDT, Mike Hommey [:glandium]
benjamin: review+
Details | Diff | Splinter Review
Add -DANDROID and include path to ASFLAGS when building for Android (2.47 KB, patch)
2012-05-21 00:39 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-05-19 01:34:23 PDT
/home/mh/mozilla-central/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_asm_mips.s:45:24: error: sys/regdef.h: No such file or directory
/home/mh/mozilla-central/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_asm_mips.s:46:21: error: sys/asm.h: No such file or directory
Comment 1 Mike Hommey [:glandium] 2012-05-19 01:59:49 PDT
There are several issues:
- ASFLAGS don't include CPPFLAGS, which is required to have the proper include path for the android system headers.
- regdef.h and asm.h are not under sys/ in the android system header for mips.
- ASFLAGS don't include -DANDROID which would allow a special case for android.
- There are different asm.h and regdef.h under asm/ and machine/ none of which allow the xptcall assembly to build.
Comment 2 Mike Hommey [:glandium] 2012-05-19 09:04:56 PDT
Created attachment 625414 [details] [diff] [review]
Use CPPFLAGS for defines and forced includes, and add them to ASFLAGS

Note that setting CPPFLAGS directly during configure fails because "$(DEPTH)/mozilla-config.h" is not valid (mozilla-config.h is not yet created, and $(DEPTH) is a make variable, not a shell variable). Thus the use of COMPILE_CPPFLAGS.
Comment 3 Mike Hommey [:glandium] 2012-05-19 09:05:53 PDT
Created attachment 625415 [details] [diff] [review]
Use CPPFLAGS for defines and forced includes, and add them to ASFLAGS

Err, the patch was not meant to contain the *.s files.
Comment 4 Mike Hommey [:glandium] 2012-05-19 09:07:03 PDT
Created attachment 625416 [details] [diff] [review]
Use the "right" headers for mips xptc assembly on android
Comment 5 Mike Hommey [:glandium] 2012-05-20 00:52:20 PDT
Comment on attachment 625415 [details] [diff] [review]
Use CPPFLAGS for defines and forced includes, and add them to ASFLAGS

Unfortunately, this breaks windows :(
Comment 6 Mike Hommey [:glandium] 2012-05-20 02:41:26 PDT
(In reply to Mike Hommey [:glandium] from comment #5)
> Comment on attachment 625415 [details] [diff] [review]
> Use CPPFLAGS for defines and forced includes, and add them to ASFLAGS
> 
> Unfortunately, this breaks windows :(

Actually, it only breaks win64, which is kind of surprising.
Comment 7 Mike Hommey [:glandium] 2012-05-21 00:39:57 PDT
Created attachment 625569 [details] [diff] [review]
Add -DANDROID and include path to ASFLAGS when building for Android

Simpler approach, which won't break anything non-Android.

Note You need to log in before you can comment on or make changes to this bug.