Last Comment Bug 756772 - IonMonkey: OOM Testing: Crash [@ js::ion::MBasicBlock::stackDepth]
: IonMonkey: OOM Testing: Crash [@ js::ion::MBasicBlock::stackDepth]
Status: RESOLVED FIXED
: crash, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem] (PTO until July 31)
:
Mentors:
: 756773 (view as bug list)
Depends on:
Blocks: 624094
  Show dependency treegraph
 
Reported: 2012-05-19 07:29 PDT by Christian Holler (:decoder)
Modified: 2012-05-23 05:51 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.61 KB, patch)
2012-05-22 03:21 PDT, Jan de Mooij [:jandem] (PTO until July 31)
dvander: review+
Details | Diff | Splinter Review

Description Christian Holler (:decoder) 2012-05-19 07:29:43 PDT
The following command crashes on ionmonkey revision 88ea2e529609 (dbg build):

js  -e 'const libdir = "js/src/jit-test/lib/";' -A 8461 -f js/src/jit-test/tests/debug/Object-parameterNames.js
Comment 1 Jan de Mooij [:jandem] (PTO until July 31) 2012-05-22 03:21:40 PDT
Created attachment 625957 [details] [diff] [review]
Patch

Propagate OOm from newBlock.
Comment 2 Jan de Mooij [:jandem] (PTO until July 31) 2012-05-22 03:51:37 PDT
*** Bug 756773 has been marked as a duplicate of this bug. ***
Comment 3 Jan de Mooij [:jandem] (PTO until July 31) 2012-05-23 05:51:02 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/7d30fd2305e5

Note You need to log in before you can comment on or make changes to this bug.