IonMonkey: Assertion failure: needsBarrier_, at ../../jscompartment.h:141

RESOLVED DUPLICATE of bug 756235

Status

()

--
major
RESOLVED DUPLICATE of bug 756235
6 years ago
6 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Other Branch
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fuzzblocker] [jsbugmon:update,ignore])

(Reporter)

Description

6 years ago
The following testcase asserts on ionmonkey revision 890dd17b4187 (run with --ion -n -m):


try {
  reportCompare(expectCompile, actualCompile, summary + ': compile actual');
} catch(ex) {}
var lfcode = new Array();
lfcode.push("gczeal(4);");
lfcode.push("try { jsTestDriverEnd(); } catch(exc1) {}");
lfcode.push("const libdir = \"/srv/repos/ionmonkey/js/src/jit-test/lib/\";");
lfcode.push("\
var appendToActual = function(s) {\
    actual += s + ',';\
  gczeal = function() { }\
");
lfcode.push("\
for (var power = 0; power < 20; ((function() {}).abstract)) {\
  var mag = \"ECMA_2\";\
  continue;   \
  gc( start, (new Date(( mag = Infinity || this ) )).getTimezoneOffset() );\
}\
");
var lfRunTypeId = -1;
while (true) {
  var file = lfcode.shift(); if (file == undefined) { break; }
  loadFile(file);
}
function loadFile(lfVarx) {
  try {
    if (lfVarx.substr(-3) != ".js") {
      switch (lfRunTypeId) {
        case 4: eval("(function() { " + lfVarx + " })();"); break;
        default: evaluate(lfVarx);
      }
    }
  } catch (lfVare) {	}
}
(Reporter)

Updated

6 years ago
Whiteboard: [jsbugmon:update] → [jsbugmon:update][fuzzblocker]
(Reporter)

Comment 1

6 years ago
JSBugMon: The testcase found in this bug no longer reproduces (tried revision 80e4ab0d24bc).
(Reporter)

Updated

6 years ago
Whiteboard: [jsbugmon:update][fuzzblocker] → [fuzzblocker] [jsbugmon:update,ignore]
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 756235
(Reporter)

Updated

6 years ago
Group: core-security
(Reporter)

Comment 3

6 years ago
A testcase for this bug was already added in the original bug (bug 756235).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.