Last Comment Bug 756783 - Cannot delete event using keyboard or toolbar
: Cannot delete event using keyboard or toolbar
Status: RESOLVED FIXED
: regression
Product: Calendar
Classification: Client Software
Component: Calendar Views (show other bugs)
: Lightning 1.7
: All Mac OS X
-- normal (vote)
: 4.0.0.1
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 08:14 PDT by Philipp Kewisch [:Fallen]
Modified: 2015-02-23 10:17 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix - v1 (1.94 KB, patch)
2015-02-20 06:44 PST, Philipp Kewisch [:Fallen]
mohit.kanwal: review+
Details | Diff | Splinter Review

Description User image Philipp Kewisch [:Fallen] 2012-05-19 08:14:34 PDT
STR:


1. select an event
2. press the delete button in the toolbar
3. press backspace to delete the event

Results:

Step 2 and 3 produce these errors:

Timestamp: 5/19/12 10:12:57 PM
Error: An error occurred executing the cmd_delete command: TypeError: focusedElement is null
Source File: chrome://global/content/globalOverlay.js
Line: 75

Timestamp: 5/19/12 10:13:08 PM
Error: An error occurred executing the calendar_delete_focused_item_command command: [Exception... "'[JavaScript Error: "focusedElement is null" {file: "chrome://calendar/content/calendar-common-sets.js" line: 331}]' when calling method: [nsIController::doCommand]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 71"  data: yes]
Source File: chrome://global/content/globalOverlay.js
Line: 75


This works in Lightning 1.5, fails in Lightning 1.7. I haven't tested 1.6. I'm testing on Mac, not sure about other platforms.
Comment 1 User image Stefan Sitter 2012-05-19 08:23:44 PDT
Seems to work for me using 1.6a2 and 1.7a1 on Windows platform.

We previously had the same problem, Bug 547593. Maybe some change regressed it for Mac OS X?
Comment 2 User image Philipp Kewisch [:Fallen] 2012-05-19 20:22:06 PDT
This seems to be off and on. Try these STR:


1. Create Event in Calendar Tab
2. Switch to mail tab, then back to calendar tab
3. Delete event with Backspace
Comment 3 User image Stefan Sitter 2012-06-08 04:36:22 PDT
As far as I remember the Backspace key was never available for deleting an event, at least on Windows platform. Steps from Comment 2 work for me using the Delete key in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Thunderbird/16.0a1 (BuildID: 20120607030200).
Comment 4 User image Philipp Kewisch [:Fallen] 2012-07-12 13:20:20 PDT
Oh right, sorry. I said backspace because on Mac the Delete key is fn+Backspace. May be a Mac issue then.
Comment 5 User image Stefan Sitter 2012-09-20 10:51:18 PDT
Setting qawanted in hope that someone with access to Mac OS X can confirm this as a problem but I still think this doesn't a block development and/or testing work.
Comment 6 User image Stefan Sitter 2013-01-24 12:37:36 PST
No complaints in the last 4 months although we did at another 3 releases -> no blocker.
Comment 7 User image Philipp Kewisch [:Fallen] 2015-02-20 06:44:46 PST
Created attachment 8567085 [details] [diff] [review]
Fix - v1

Still getting this once in a while, this should fix the error. Can you give it a quick test? My build is totally messed up, but this does seem to fix it for me.
Comment 8 User image Mohit Kanwal [:redDragon] 2015-02-20 11:39:22 PST
Comment on attachment 8567085 [details] [diff] [review]
Fix - v1

Review of attachment 8567085 [details] [diff] [review]:
-----------------------------------------------------------------

Although the problem does not seem to occur for me on Mac OSX (I am on 10.10) nonetheless, the patch looks fine to me.
Comment 9 User image Philipp Kewisch [:Fallen] 2015-02-22 16:51:07 PST
Pushed to comm-central changeset 516b43f6d312

Note You need to log in before you can comment on or make changes to this bug.