crash on quit in nsOutlinerBodyFrame::Destroy() [changing 3pane layout?]

VERIFIED DUPLICATE of bug 74902

Status

--
critical
VERIFIED DUPLICATE of bug 74902
18 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: sspitzer)

Tracking

({crash})

Trunk
PowerPC
Mac System 9.x
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
another tricky crash on quit bug --not sure if this is mailnews, theme, or
outliner [toolkit] issue. pls do reassign as needed.

using 2001.04.11.08 commercial verif bits. seems to only occur on Mac. i've
gotten four identical stack traces --each time i was using the modern-mojo
[test] theme, as well as viewing mailnews.

i've tried to narrow down a simplified set of steps, but i cannot seem to get a
reliable recipe --but it might involve switching btwn the regular and alternate
3pane layouts...

1. in mailnews window, open Preferences and change the layout to the alternate
3pane style.
2. quit the app --> crash.

if you don't crash with those steps, try going back and forth btwn the two
layout styles, and maybe even having a browser window open when you quit [esp
since you may encounter bug 75114].

trace info for talkback incident ID 28998741:

0x00220004 
nsCOMPtr_base::assign_from_helper() [nsCOMPtr.cpp, line 63] 
nsOutlinerBodyFrame::Destroy() [nsOutlinerBodyFrame.cpp, line 305] 
nsFrameList::DestroyFrames() [nsFrameList.cpp, line 41] 
nsContainerFrame::Destroy() [nsContainerFrame.cpp, line 95] 
nsBoxFrame::Destroy() [nsBoxFrame.cpp, line 1006] 
nsFrameList::DestroyFrames() [nsFrameList.cpp, line 41] 
nsContainerFrame::Destroy() [nsContainerFrame.cpp, line 95] 
nsBoxFrame::Destroy() [nsBoxFrame.cpp, line 1006] 
nsFrameList::DestroyFrames() [nsFrameList.cpp, line 41] 
nsContainerFrame::Destroy() [nsContainerFrame.cpp, line 95] 
nsBoxFrame::Destroy() [nsBoxFrame.cpp, line 1006] 
nsFrameList::DestroyFrames() [nsFrameList.cpp, line 41] 
nsContainerFrame::Destroy() [nsContainerFrame.cpp, line 95] 
nsBoxFrame::Destroy() [nsBoxFrame.cpp, line 1006] 
nsFrameList::DestroyFrames() [nsFrameList.cpp, line 41] 
nsContainerFrame::Destroy() [nsContainerFrame.cpp, line 95]
(Reporter)

Updated

18 years ago
Keywords: crash, nsbeta1

Comment 1

18 years ago
I've seen this too, when closing the mail 3-pane.
this is a dup of a bug that hyatt owns.

several dups on this one today.

Comment 3

18 years ago
bug 74902. Dah? Nyet? Reopenski?

*** This bug has been marked as a duplicate of 74902 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
spasiba, v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.