2 new suggestions for firefox .. .

VERIFIED INVALID

Status

()

VERIFIED INVALID
7 years ago
7 years ago

People

(Reporter: ukrainianconsular, Unassigned)

Tracking

15 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120518030516

Steps to reproduce:

I've tried downloadwith 0.0.9+ hacked & updated but it doesn't 
seem to work well . .. I believe there's an issue with that addon,
when i click on java encrypted links that lead me to download a file and that ie manages properly but not firefox, firefox launches daum potplayer for any encrypted links that lead me to download a file. and daum potplayer is referenced in downloadwith addon preferences for Specific files only & not all .. .

Even with downloadwith, i get the internal firefox dl manager
that quickly pops up when i would want an url to be passed
directly to the media player for streaming.

I want this to happen when i click on a link & without having
to right click and select an application like in launchy.

I've installed launchy 4.4 and i dont have presets either .. .

My dream would be to have a downloadwith (anyapp.exe)
in the firefox dl manager & to have each action set .. .


Actual results:

_


Expected results:

Allow java encrypted urls that lead me to download files (i can chose either i want to save it, open it or not afterwards), like ie, to be funactional in firefox.

I know that for security reasons, you don't want to activate those java encrypted
download links but, you could add an internal system to make sure, nothing else
happens in the background and the file/s is transmitted to the user if there's any,
and after that, it's a user's choice .. . to either open, save it or not, people don't
java encrypted files to open or save files, so anybody can catch viruses even with
unhidden urls that clearly show the file/s to download .. .

& Another suggestion for firefox:

A new feature:

in the download manager & in options/applications:

Download with (The Application i'd browse and select.exe)
& each media file i need to download will have a saved action .. .

It would be a plus nowadays, when ie does even better than what i suggest,
ie recognizes the media extension in the registry & passes it directly to wmp .. .

Why external media players ? ability to save, convert etc etc, more freedom than
media player's plugins .. .

Comment 1

7 years ago
I have no idea about these add-ons, but they have nothing to do with Firefox itself. You might get help in the forums of these add-ons instead.

Your other proposal is interesting but Firefox is not a media converter tool. This could maybe get implemented via a plugin but converting media is not a core task of a browser.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
mid-air ...

Your report is a little bot confusing.
We accept only one issue or one enhancement request in one single bug report and you have to search for existing reports before creating new ones.

We are not responsible for any addons and you have to report issues with the downloadwith addon the the addon author. I don't know what "java encrypted links" are and you are misssing clear steps to reproduce
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

7 years ago
who said firefox converts media ? i did ? and i know u guys are fast in deductions, but the strangest part is you're fast in terms of negativism.

& java encrypted links are links that call the right link for a file download
in a javascript method .. .

i don't have the right programming term, i have to go to school for that first and then, make sure we speak the same language which will prevent u from thinking, guys .. .

SLEEP WELL, CLOSED TOPIC & VIVA FIREFOX'S EVOLUTION.

IM OUTTA HERE CHILDREN.

Comment 4

7 years ago
(In reply to ukrainianconsular from comment #3)
> & java encrypted links are links that call the right link for a file download
> in a javascript method .. .

Javascript is not the same as Java. And the link sure is not encrypted.

Comment 5

7 years ago
ukrainianconsular: No offense intended, but to avoid future disappointments I recommend reading https://developer.mozilla.org/en/Bug_writing_guidelines for how to provide a good, specific bug report /feature request that is easier to read and to reproduce for developers. As Matthias and me said, it was unfortunately rather hard to read this report. :-/
You need to log in before you can comment on or make changes to this bug.