Slow unresponsive script warning triggered by the chinadaily site

RESOLVED WORKSFORME

Status

()

Core
XPConnect
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Devoti Paolo, Unassigned)

Tracking

({regression})

12 Branch
All
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

open page
http://www.chinadaily.com.cn/world/2012-05/20/content_15340726.htm


Actual results:

firefox frezes and after a while prompts a dialog about a script
Script: http://monitor.yigao.com/info.js:1


Expected results:

should not freeze and allow to keep browsing other pages/tabs
Last good nightly: 2010-10-13
First bad nightly: 2010-10-14

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f6e81dd5a125&tochan
ge=ad0a0be8be74
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: Untriaged → JavaScript Engine
Ever confirmed: true
Product: Firefox → Core
QA Contact: untriaged → general
Hardware: x86_64 → All
Keywords: regression
Summary: firefox frozen while executing script → Slow script warning triggered by the chinadaily site
Whiteboard: [js:p1:fx16]

Updated

6 years ago
Assignee: general → luke

Comment 2

6 years ago
I looked into this a bit.  The site seems to be ilooping in a script doing top.document.location, document.referrer, top.document.location.document.referrer, and window.parent.document.location.  FF shows a single error "initCookie is not defined".  Chrome shows the same error but also a bunch of security errors (accessing cross-domain window) that we don't report.  This would seem to finger something in our DOM/XPConnect logic so I'm tentatively booting over to XPConnect.

It would be really helpful to get a regressing cset to take this bug further.
Assignee: luke → nobody
Component: JavaScript Engine → XPConnect
Keywords: regressionwindow-wanted
QA Contact: general → xpconnect
Whiteboard: [js:p1:fx16]

Comment 3

6 years ago
Regression window(TM):
Good:
http://hg.mozilla.org/tracemonkey/rev/edb0506b0c23
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101010 Firefox/4.0b8pre ID:20101010054050
Bad:
http://hg.mozilla.org/tracemonkey/rev/9cb987478e60
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101010 Firefox/4.0b8pre ID:20101010174704
Pushlog:
http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=edb0506b0c23&tochange=9cb987478e60

Last Good: 659215248912
First Bad: 6c45f066ed17

Comment 4

6 years ago
Is that the initial compartments landing?
Sure looks like it, yes.

Updated

6 years ago
Summary: Slow script warning triggered by the chinadaily site → Slow unresponsive script warning triggered by the chinadaily site
Keywords: regressionwindow-wanted
This seems to WFM now.
Either the page changed or the bug is fixed in current builds. I can confirm that it works with Firefox15.0.1

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.