installer stops with "-229 SCRIPT_ERROR"

VERIFIED FIXED

Status

--
blocker
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: ssu0262)

Tracking

({smoketest})

Trunk
x86
Windows 2000
smoketest

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
the installer dated 12-04-2001 size 8.347.360 stops with "-229 SCRIPT_ERROR".

     ** fProgram                : C:\Program Files\Mozilla.org\Mozilla\
     ** ERROR (-230): Create Folder: C:\Documents and Settings\All Users\Start 
Menu\Programs\Mozilla
     ** Line: 371	cf is not defined

     Install **FAILED** with error -229

     Install **FAILED** with error -229
(Reporter)

Comment 1

18 years ago
it's due to:
getFolder(cf,"help.jar"),"content/help/");
    registerChrome(LOCALE | DELAYED_CHROME, 

in the browser.xpi file

"cf" is not defined anywhere....
(Reporter)

Comment 2

18 years ago
Caused by checkins to bug 74132:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&su
bdir=mozilla/xpinstall/packager/windows&command=DIFF_FRAMESET&file=browser.jst&r
ev1=1.27&rev2=1.28&root=/cvsroot

Comment 3

18 years ago
Surely a smoketest blocker...
Keywords: smoketest

Comment 4

18 years ago
Created attachment 30575 [details] [diff] [review]
patch to windows\browser.jst

Comment 6

18 years ago
have the patch in hand. ACCEPTING
Status: NEW → ASSIGNED

Comment 7

18 years ago
r=jag

Comment 8

18 years ago
Just checked in the patch. Marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

18 years ago
sure is fixed!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.