[PP] {GFX Scrollbar}Select - Size attribute is ignored on Linux.

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Chris Petersen, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Version:Apprunner
Build: 1999060308
Platform: Linux
Other Platforms: Works correctly on Mac and Windows.

Expected Results: The Select element's size attribute has been assign a value of
4. The Select element should display all four menu items without a active scroll
bar.

What I got: However, the select element shows only three list items when
displayed in the browser window. The user must scroll to see the fourth list
item.

Steps to Reproduce:

1) Open the sample file in Apprunner.
2) Notice the select element only displays three list items.
(Reporter)

Comment 1

19 years ago
Created attachment 336 [details]
The size attribute seems to be ignored.

Updated

19 years ago
Assignee: karnaze → kmcclusk

Comment 2

19 years ago
Kevin, if this is not gfx related, please reassign to Ramiro, under the
assumption that it is Linux only.

Updated

19 years ago
Assignee: kmcclusk → ramiro
Ramiro, I'm reassigning to you since its a Linux [PP] specific issue

Comment 4

19 years ago
Moving all Widget Set bugs, past and present, to new HTML Form Controls
component per request from karnaze.  Widget Set component will be retired
shortly.

Updated

19 years ago
Assignee: ramiro → kmcclusk

Comment 5

19 years ago
Yeah, i see the scrollbar.  But, the code that manages the scrollbar is all gfx
widget xp code.

back to kmcclusk.

Updated

19 years ago
Assignee: kmcclusk → rods
Rod, could you check this out after you checkin your changes to the select? It
may be an off by 1 problem which causes the scrollbar to appear on Linux, but
not on WIN32.
(Assignee)

Updated

19 years ago
Summary: [PP] Select - Size attribute is ignored on Linux. → [PP] {GFX Scrollbar}Select - Size attribute is ignored on Linux.
(Assignee)

Comment 7

19 years ago
Changed summary, will review after GFX scrollbar work

Updated

19 years ago
Blocks: 18951
(Assignee)

Comment 8

19 years ago
changed to M14

Updated

19 years ago
Assignee: rods → ckritzer

Updated

19 years ago
Assignee: ckritzer → rods
QA Contact: phillip → ckritzer
(Assignee)

Comment 9

18 years ago
Work for me in todays build.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

18 years ago
Fixed in the May 15th build.
Status: RESOLVED → VERIFIED

Updated

18 years ago
No longer blocks: 18951
You need to log in before you can comment on or make changes to this bug.