Note: There are a few cases of duplicates in user autocompletion which are being worked on.

update YSI urls for creating accounts and learning more

RESOLVED FIXED in Thunderbird 15.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

unspecified
Thunderbird 15.0
x86_64
Windows 7

Thunderbird Tracking Flags

(thunderbird13+ fixed, thunderbird14+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 625760 [details] [diff] [review]
proposed fix

YSI wants us to use

        "https://www.yousendit.com/thunderbird-about-yousendit?s=4001583&cid=pm-4001583" for learn more and "https://www.yousendit.com/litesignup?s=4001583&id=pm-4001583" for needAnAccount.
Attachment #625760 - Flags: review?(mconley)
(Assignee)

Comment 1

5 years ago
we'll want to land this on aurora and beta asap.
status-thunderbird13: --- → affected
status-thunderbird14: --- → affected
tracking-thunderbird13: --- → +
tracking-thunderbird14: --- → +
Comment on attachment 625760 [details] [diff] [review]
proposed fix

Review of attachment 625760 [details] [diff] [review]:
-----------------------------------------------------------------

Besides the & problem, this looks good (though I didn't compile / test it...vacation 'n all. ;) )

-Mike

::: mail/components/cloudfile/content/YouSendIt/settings.xhtml
@@ +19,5 @@
>      <form id="provider-form" onsubmit="return false;">
>        <label for="username">&youSendItSettings.username;</label>
>        <input id="username" type="text" required="true"/>
>        <div id="learn-more" class="float-right">
> +        <a href="https://www.yousendit.com/thunderbird-about-yousendit?s=4001583&amp;cid=pm-4001583">&youSendItSettings.learnMore;</a>

I think the &amp; in the URL is wrong - I think that's supposed to be a pure &.  Same below.
Attachment #625760 - Flags: review?(mconley) → review+
(Assignee)

Comment 3

5 years ago
heh, if & worked, this would have taken me 2 minutes instead of a couple hours. I needed to use &amp; to get the UI to not get a xml error.

I'll let you be back from vacation to try it out :-) No hurry, just wanted to get the process going...enjoy your day off!
(Assignee)

Comment 4

5 years ago
fixed on trunk - I'll push to alpha and beta.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

5 years ago
trunk - http://hg.mozilla.org/comm-central/rev/2e9cb0ffa579
aurora - http://hg.mozilla.org/releases/comm-aurora/rev/9ddcd204a766
beta - http://hg.mozilla.org/releases/comm-beta/rev/7599f7180908

beta didn't apply cleanly, so I had to transplant by hand.
status-thunderbird13: affected → fixed
status-thunderbird14: affected → fixed
Target Milestone: --- → Thunderbird 15.0
You need to log in before you can comment on or make changes to this bug.