Closed Bug 757326 Opened 8 years ago Closed 6 years ago

netflix zoom in = header bar missing

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jdavis, Unassigned)

References

()

Details

(Whiteboard: [Engagement][UserEngagement])

Attachments

(2 files)

Attached file screenshots
Web page or screen you were on when you saw the issue: 
netflix.com

Steps to reproduce:
1. go to netflix.com & login
2. view page like "instant queue" - note top navigation bar with "search"
3. zoom in
4. navigation header disappears

What you expected: 
navigation header should reappear after zoom like stock browser

Crash report ID (if applicable):
Unfortunately I don't have an netflix account to test this. Most likely that bar is a position:fixed element, and so this bug may be fixed with bug 607417.
I just took another look with the update, and the header does follow you when you zoom in, but it doesn't allow you to scroll to the left/right to get to the search box on the right hand side of the navigation bar.  See screenshot of where I have scrolled to the right, but the beginning of the navigation bar is all I can see no matter how far right I scroll.

I tried it on the stock browser and the stock browser seems to have changed its behavior. The navigation bar doesn't follow you when you zoom in.

Netflix has a free 30-day trial, or I can loan you my login if you'd like to see it in action.  Let me know how I can best help.
Attached image screenshot post-update
can't see right hand-side of navigation bar no matter how far right you scroll.
Yeah, this looks like it's just a wide position:fixed element on the page, and so there's not much we can do on the browser side to fix it. The page needs to be better designed for small screens. Moving this bug to evangelism.
Component: General → Evangelism
QA Contact: general → evangelism
The only snag with that potentially is that it does work well in the stock browser.
If the behaviour changed in the stock browser (as you said in comment #2) it's likely that they're serving the stock browser different content now than they were before, and it no longer has the position:fixed bar. If they do the same for us then it would just as well in Fennec as it does in the stock browser.
(In reply to Kartikaya Gupta (:kats) from comment #6)
> and it no longer has the position:fixed bar.

By this I mean they still have the bar, they just make it part of the normal content flow rather than position:fixed.
Component: Evangelism → Mobile
OS: Mac OS X → Android
Product: Firefox for Android → Tech Evangelism
Hardware: x86 → ARM
Version: Trunk → unspecified
Is this issue still valid?
I'm inclined to close it as INVALID (or at least, NOTAPROBLEMANYMORE). 

We don't get a fixed position header, we get the same experience as Chrome. The native Android browser does have a fixed position header, but it suffers from the original bug reported--you can't actually get to the rest of the content.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.