scrollwheel event data is dependent on Windows scrollwheel settings

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Jurek R., Unassigned)

Tracking

12 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; de-de) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1

Steps to reproduce:

I tried to read out the delta value of the DOMScrollWheel event using Javascript. I want to program a slideshow where one tick on the scrollwheel moves the show by one photo.

This is currently impossible to do with Firefox/Windows.

This problem only affects Firefox on Windows. My test system was Windows 7 home, Firefox 12.


Actual results:

If I read out the scrollwheel event data, the delta offset offset from a the DOMMouseWheel javascript event, only on Firefox it will return different values, depending on the Windows settings for the scrollwheel.

So if the scrollwheel settings in Windows are higher (for example 10 rows), the javascript function will return higher values and so on. All other browsers return a constant change of the value, so it is easy to normalize it there. But not with Firefox.



Expected results:

Firefox/Windows should return constant values, not depending on the Windows scrollwheel settings. Firefox Mac, Chrome, Safari, IE9 do it like this.
It's by design. The behavior provides smoother scrolling for users.

The detail value of DOMMouseWheel indicates the amount of lines to be scrolled on the nearest ancestor scrollable element of the event target. So, if you need to accumulate the each event's delta value and when it reaches good amount, you should do something to do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.