Enable IPv6 on UnrealIRCd

RESOLVED FIXED

Status

Infrastructure & Operations
Infrastructure: Other
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: XioNoX, Assigned: lerxst)

Tracking

Details

(Reporter)

Description

6 years ago
Concrete now has IPv6 connectivity but the IRC daemon does not listen on the v6 address.

If the current instance has been compiled with v6 support, a restart should be enough
otherwise [1] says "Your OS needs to have IPv6 support and you need to enable IPv6 support in UnrealIRCd during ./Config as well."

If we have to recompile it, it's maybe a good opportunity to upgrade to the latest build [2].

It would be nice to have this at least 1 week before IPv6 launch day (6-6-12).

[1] http://www.vulnscan.org/UnrealIRCd/unreal32docs.html#feature_ipv6
[2] http://www.unrealircd.com/txt/unreal3_2_9_release_notes.txt

thx
(Reporter)

Comment 1

6 years ago
fyi, its IP is 2620:101:8008:74::1:3
(Reporter)

Updated

6 years ago
Duplicate of this bug: 563646

Updated

6 years ago
Assignee: server-ops-infra → bhourigan
Group: infra

Updated

6 years ago
Duplicate of this bug: 384754
For the record, I just checked, and our build was indeed compiled without IPv6 support, so we will need to rebuild to get it.

Updated

5 years ago
Depends on: 881009

Updated

5 years ago
Depends on: 858534
Component: Server Operations: Infrastructure → Infrastructure: Other
Product: mozilla.org → Infrastructure & Operations

Comment 5

4 years ago
Any progress on this? There are a load of irccloud.com users on irc.mozilla.org and in general IPv6 is far more resilient to the DDoS attacks we receive from time to time. This would greatly help us maintain connectivity for our and your users.
This is currently on hold. We're working on a larger project to improve
IRC and IPv6 support will be included then.

Updated

4 years ago
Assignee: bhourigan → dparsons
(Assignee)

Comment 7

4 years ago
I'm in the process of building a new irc network to take over the current one, and it will be hosted in EC2, which does not support ipv6. I might set up an ipv6-only server, hosted in scl3, but that's coming a bit later. WONTFIXing this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 8

3 years ago
Our test network now has an ipv6 server, and if all goes well, it will go into production soon. There's an AAAA record on irc.allizom.org for it.
Resolution: WONTFIX → FIXED
You need to log in before you can comment on or make changes to this bug.