<input type=number> should allow input of floating point number

RESOLVED FIXED in Firefox 15

Status

()

Firefox for Android
Keyboards and IME
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: raphc, Assigned: raphc)

Tracking

Trunk
Firefox 15
All
Android
Points:
---

Firefox Tracking Flags

(firefox14 affected)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.75 KB, patch
cpeterson
: review+
mounir
: checkin+
Details | Diff | Splinter Review
(Assignee)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120521030525

Steps to reproduce:

focus a <input type=number>


Actual results:

android numeric keyboard allowing to type decimal number


Expected results:

android keyboard allowing to type decimal number + point
OS: Linux → Android
Hardware: x86_64 → All
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 581596
(Assignee)

Comment 1

6 years ago
Created attachment 626035 [details] [diff] [review]
patch
Attachment #626035 - Flags: review?(mark.finkle)
Comment on attachment 626035 [details] [diff] [review]
patch

Raphael - This looks good to me, but I am passing review over to Chris Peterson, who knows more about GeckoInputConnection.java
Attachment #626035 - Flags: review?(mark.finkle) → review?(cpeterson)
Comment on attachment 626035 [details] [diff] [review]
patch

Thanks for the patch, Raphael. Your code change looks good to me.

Two suggestions for future patches:

1. You should change your patch's commit message from "r=raphael" to "r=cpeterson" when you check it in. You are the patch author, not the reviewer. <:)

2. When you post a patch for review, you should typically leave the "r=" blank because the reviewer has not granted an r+ yet. You can change the blank "r=" to "r=reviewername" when you commit your r+'d patch to hg.
Attachment #626035 - Flags: review?(cpeterson) → review+
1. mfinkle, is this <input> fix something you would accept for Aurora? The code change is small, but not a critical bug fix.

2. Assigning bug to Raphael, since he fixed it.
Assignee: nobody → raphael.catolino
Status: NEW → ASSIGNED
status-firefox14: --- → affected
status-firefox15: --- → affected
(Assignee)

Comment 5

6 years ago
Created attachment 626078 [details] [diff] [review]
patch

changed r=cpeterson in comment
Attachment #626035 - Attachment is obsolete: true
Attachment #626078 - Flags: review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Keywords: checkin-needed
Target Milestone: --- → Firefox 15
Comment on attachment 626078 [details] [diff] [review]
patch

Pushed in mozilla-inbound.
Attachment #626078 - Flags: checkin+
https://hg.mozilla.org/integration/mozilla-inbound/rev/dc6e7af2650c

Comment 8

6 years ago
https://hg.mozilla.org/mozilla-central/rev/dc6e7af2650c
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
status-firefox15: affected → ---
You need to log in before you can comment on or make changes to this bug.